image aligned left makes enclosing table wider than the browser window

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011101
BuildID:    2001110109

In the page at http://www.sierraviewcc.com/history.html, the text area is
enclosed in a table cell. The second image on the page has the attribute
align=left set. This causes the enclosing table to not resize properly, and when
viewed at 800x600 requires a little bit of right scrolling to view the complete
page. In other browsers, including Mozilla 0.9.4 milestone under Windows NT
(don't know about Linux), the page can be made much smaller before horizontal
scrolling becomes necessary.

Other notes: if you enclose the text area of the page in its own table, the page
sizes properly. If you change the size of the text in the view menu, when the
page reflows it sizes properly, even if you set it back to the original text
size. However, if you reload the page the problem comes back. If there are no
images with align=left set on the page, the problem never occurs. Explicitly
setting the table width doesn't appear to have any effect, nor does eliminating
all width attributes entirely. Making the image narrower (just changing the
width attribute; it's not actually necessary to change the image itself) fixes
it; it appears from the way it behaves that something related to the image size
is setting the page to an explicit width when align=left is used.

Reproducible: Always
Steps to Reproduce:
1. Load http://www.sierraviewcc.com/history.html
2. Size browser to approximately its maximized size at 800x600, or a little smaller


Actual Results:  The page will be sized slightly wider than the browser window,
requiring right scrolling to view the entire page.

Expected Results:  The text and images should be reflowed to fit within the
available space (there should be more than enough space for everything at that
size).

As noted above, the Mozilla 0.9.4 milestone release running under Windows NT 4.0
doesn't exhibit the problem behavior. I don't know if 0.9.4 under Linux works; I
just happened to have a Windows box running 0.9.4 handy so checked it there, and
it was okay.
WFM, yesterday's linux CVS.

Comment 2

17 years ago
WFM in the latest build (2001-11-15-06) . Reporter, please try with a newer build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

17 years ago
Tried with the lastest nightly and the problem still exists. As I say, it works
properly with 0.9.4, so something has definitely changed. Again, it's sensitive
to both the browser's window size and the font size, so it may take a little
playing with those to see the problem.
(Reporter)

Comment 4

17 years ago
Just downloaded the latest nightly, tried it, problem's still there.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Reporter: can you attach a screenshot to this bug?  (using the Create a New Attachment link)

Comment 6

17 years ago
the server must be down, I cannot access
http://www.sierraviewcc.com/history.html to verify the problem
(Reporter)

Comment 7

17 years ago
Created attachment 64934 [details]
Screenshot of offending page

This screenshot shows the page as rendered when it's first loaded. It's taken
with the latest nightly. As noted, if I enclose the text area of the page in a
single cell table, no right scrolling is required. Note that they let their
main domain name lapse; the page can still be accessed at www.sierraviewcc.org.
(Reporter)

Comment 8

17 years ago
Created attachment 64937 [details]
Second screenshot after changing font size

For the sake of completeness, this is a second screenshot. The only thing I did
after taking the first one was hit Ctrl+ Ctrl- to make the font larger then
regular size again. As you can see, it reflows properly after doing that, but
if I hit reload it'll be back to right scrolling. Hope this helps.

Comment 9

17 years ago
ah, looking at the screenshot I see why I couldn't access the page -- that 
should be .org not .com, updated the URL string.

Looking at the source, the table is set to a width of 670, I suspect that when 
you view it in a 800x600 setting, you are exceeding the width in the table, 
causing the scrollbar. After remvoing the width attributes and removing and 
readding the align attributes, the scrollbars only appear when the images begin 
to align with the edge of the window. This same behavior is presented in IE6. I 
do not believe this is a bug. I am closing this out as WFM, if you disagree 
please let me know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

17 years ago
The width is set to 670 in order for the page to work reasonably in NS4.x, but
is set to 100% in the style sheet so it can size with the browser. This
technique has worked reliably for me until this point, although I could have
just been lucky.

However, it doesn't explain why making the font size bigger (using Ctrl+) will
cause the page to render without right scrolling, or why it only happens when
there is a left aligned image in the page, or why enclosing the text and images
in a single cell table (nested within the main table) will make it render
correctly. It seems to me that none of these should make a difference if your
theory as to the problem is correct. Nor does it explain why it works fine in
versions of Mozilla prior to 0.9.5 and in every version of IE I have tried
(admittedly IE6 is not one of them).

At this point I am resigned to the fact that it won't be fixed, but I must say
I'm very disappointed. Much has been said about the fact that open source
results in less buggy software, but it seems to me that "it works for me so it
must not be a problem" is exactly the sort of behavior we expect from Microsoft,
so where's the benefit?
You need to log in before you can comment on or make changes to this bug.