Closed Bug 1081231 Opened 5 years ago Closed 2 years ago

v2.1 Rocketbar locks up after opening and closing several browser windows - doesnt accept input

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.1 --- affected

People

(Reporter: sfoster, Unassigned)

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

Found while attempting to repro bug 1078859. Same STR:

1) Search via Rocketbar or Browser URL bar. Note that searching via Homescreen rocketbar will make another window, as opposed to searching on Browser URL bar will get the resultant search on the same window.
2) Make three windows displaying search results
3) On one of the browser window, tap on '...' icon > Show windows, and kill all browser windows
4) Repeat steps 2-3 two more times and bug will occur

Expected result: 
We can continue to open new browser windows and close them without deterioration in performance or functionality

Actual result: 
After opening and closing just 3-5 browser windows, the rocketbar ceases to function -  tapping on it doesnt bring up the keyboard or have any visible effect
Note, the home button still works as does holdhome to bring up task manager. Going into task-manager then selecting the browser/search window restores the ability to use the rocketbar. I did get about_memory report on this but I'm not sure its a memory issue?
More interesting details: 

When the rocketbar issue reproduces, on the new tab/'Top Sites' (search app) click the [] icon to the right of the address bar to show open browser windows. Close all windows and the task-manager hides, dropping you back to the homescreen. For me, the homescreen has a black background at this point. Also, when you then holdhome to show the task-manager, it says "Your recent browser windows show up here" - which it should only say when using the show windows menu/button. So this sounds like a possible regression from/around bug 1074512?
Just tried to reproduce this again using the STR (Flame, 319MB, v2.1) to investigate and failed. It was reproducible on-demand before (before I re-flashed), not sure what the variables are now. Would be happy to close this as Works For Me if no-one else can repro.
Keywords: qawanted
Hardware: x86_64 → ARM
Summary: Rocketbar locks up after opening and closing several browser windows - doesnt accept input → v2.1 Rocketbar locks up after opening and closing several browser windows - doesnt accept input
I was unable to reproduce this issue on the latest 2.1 Flame KK or 2.2 Flame KK after 15 closed windows on each build.

Environmental Variables (shallow flash):
Device: Flame 2.1
BuildID: 20141011150624
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: e96a7a4f3bbe
Version: 34.0a2 (2.1) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables (shallow flash):
Device: Flame 2.2
BuildID: 20141012115053
Gaia: 3b81896f04a02697e615fa5390086bd5ecfed84f
Gecko: 199fb29c3467
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Re-adding the qawanted tag so others can attempt to reproduce.
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
I'm also unable to reproduce this bug. I actually never saw this bug when I wrote the steps quoted at comment 0. Removing qawanted tag due to inability to repro.

Tested on:
Device: Flame 2.1 (shallow flash, 319MB mem)
BuildID: 20141013062451
Gaia: f5d4ff60ffed8961f7d0380ada9d0facfdfd56b1
Gecko: 47cc92f8ab46
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.