Localize privacy coach add-on

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Margaret, Assigned: pascalc)

Tracking

35 Branch
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I assume we're going to want this add-on localized.

Jenn, can you help coordinate this? In the past, Pascal has helped me localize the Goal.com and Home Feeds add-ons for promotions, maybe he would be able to help us with this project as well.

Unfortunately, there are a lot more strings because we're shipping a welcome page in the add-on. Right now Robin and I landed some initial copy, but we're waiting for Arcadio to finalize the copy.

The current strings are in here:
https://github.com/leibovic/privacy-coach/tree/master/locale/en-US
Flags: needinfo?(jchaulk)
Adding Deb as she's the product lead on this initial now that she's back.
huh - I was obviously distracted when typing this. 

'... on this initiative...'
(Assignee)

Comment 3

3 years ago
I am going to take this one and will use the same process as for the previous add-ons localization (.lang files for translation and tracking, automatic conversion to dtd/properties and I will do the pull requests on github to update the add-on). Do you have a timeline/list of desired locales/short description of the project somewhere so as that I catch up with this project? Thanks
Assignee: nobody → pascalc
(Reporter)

Updated

3 years ago
Depends on: 1082089

Comment 4

3 years ago
is the feature set for the addon pretty much complete?

and are we at string freeze?

should probably add tracking for these two milestones on the daily stand up call if not.
(Reporter)

Comment 5

3 years ago
(In reply to chris hofmann from comment #4)
> is the feature set for the addon pretty much complete?

Roughly. We decided we weren't happy with the features that are currently in the master branch, so we're working in a separate branch to fix our complaints. We should be feature complete by the end of the week.

> and are we at string freeze?

No. There is going to be a lot of string churn with this new feature work, so we shouldn't point localizers at this yet.

I will aim to have the feature work done by the end of the week, and then get feedback on the copy from UX/Product/Marketing. So hopefully we can be string frozen by some time next week.
(Assignee)

Comment 6

3 years ago
Any news? I started looking at this project code locally and there is a significant volume of words in the draft (~1400), so the sooner we get final content, the better. 

I also noticed several entities that are empty with that form:
<!ENTITY features.pb.desc.post "">

and sentences cut on several entities, one only with punctuation:
<!ENTITY addons.more.pre "For even more add-ons, you can explore the full set of ">
<!ENTITY addons.more.link "Security &amp; Privacy add-ons">
<!ENTITY addons.more.post ".">

Can we avoid that and just have one entity please? Thanks
(In reply to Pascal Chevrel:pascalc from comment #6)
> Can we avoid that and just have one entity please?

That's the most common way to create sentences with only part of the text associated to a link (pre-link, link, and post-link).

I believe that the only alternative is to use .properties files and placeholders, which comes down to 2 strings and a lot more complexity in the code.
(Reporter)

Comment 8

3 years ago
(In reply to Francesco Lodolo [:flod] from comment #7)
> (In reply to Pascal Chevrel:pascalc from comment #6)
> > Can we avoid that and just have one entity please?
> 
> That's the most common way to create sentences with only part of the text
> associated to a link (pre-link, link, and post-link).

Yes, I was trying to just follow the way I've seen this done in Firefox product code.

I can add localization notes to better explain what's going on.

We're still waiting on the final copy, but I think we should have something by the end of this week. I know this is a lot of text to translate, I'm sorry :(

jchaulk is managing the timeline, and she has been really pushing to get this copy finalized ASAP.
FYI that the date we are pushing for is this Friday the 24th.
(Assignee)

Comment 10

3 years ago
(In reply to Jenn Chaulk from comment #9)
> FYI that the date we are pushing for is this Friday the 24th.

European time? If not, that means working on the week end for me or push that to Monday
Hi Pascal, it was end of day PST when the resource were updated, so looks like kicking off today (Monday) it is!  Here is the location, copied from the creative bug:

...updated the text, pushed the changes to the github repo [1] and posted a test version of the add-on [2]

[1] https://github.com/leibovic/privacy-coach
[2] http://people.mozilla.org/~mfinkle/coach.xpi

Let me know if you need anything else
Flags: needinfo?(pascalc)
(Assignee)

Comment 12

3 years ago
Can you provide the list of targetted locales? For the moment I am working on the assumption that it is the same list that was asked for the addons we did for the Australis launch (de, es-ES, fr, id, it, ja, pt-BR). 

Also, I am guessing that there will be a submission process to AMO to get it hosted, what is the deadline to provide localizations before the submission and how often will we be able to update the xpi on AMO after the submission? Thanks
Flags: needinfo?(pascalc)
Adding dria to double confirm, but should be just de and fr for the Nov 10 launch.

I've passed the en version of the add-on AMO to review and approve already.  They say they just need the final files a couple of days before if it's 'pre-approved'.  I'll check on updates after submission.
Flags: needinfo?(jchaulk) → needinfo?(deb)
We're verifying with Karen and Arcadio - will update here ASAP. Sorry for the delay.
From Arcadio:  Here is the list of priority locales for the 10th Anniversary campaign. I'm agreeing with Karen to match regions where desktop will be creating awareness on the launch date.

US
Germany
Russia
France
Brazil
India
Indonesia
Poland
Spain
Mexico
Japan
Poland
Hungary
(Assignee)

Comment 16

3 years ago
If I match it with languages we support it is:
de, ru, fr, pt-BR, id, pl, es-ES, es-MX, ja, hu

We support various languages in India but have very marginal user base for Desktop localized builds, people use our english builds, so not sure if it is worth localizing the add-on for these Indic locales as the Desktop launch impact will be mistly via English builds, what do you thuink Jenn?

Potentially we could also see id we could have minor locales in Spain, Catalan probably has more Desktop users than all Indic locales together in India.
Flags: needinfo?(jchaulk)
I didn't catch the India issue when I pasted that in!  Oops!  I'll have to defer to Karen and Arcadio on which Indic locales they want to go with (if even any).  Will also check on CA.
Do you have any plan to localize?
Mozilla staffs will localize? Request for communities?

Should we (Mozilla Japan) call for l10n or just review your l10n?
Tell me what should I do (and also schedule) then I'll help for Japanese (ja) locale.
(Assignee)

Comment 19

3 years ago
(In reply to dynamis (Tomoya ASAI) from comment #18)
> Do you have any plan to localize?
> Mozilla staffs will localize? Request for communities?
> 
> Should we (Mozilla Japan) call for l10n or just review your l10n?
> Tell me what should I do (and also schedule) then I'll help for Japanese
> (ja) locale.

Tomoya, you will get these files for localization today, I am preparing the project.
(Assignee)

Comment 20

3 years ago
Localization is launched for the locales we are sure of, here is a dashboard to follow progress:
https://l10n.mozilla-community.org/~pascalc/langchecker/?locale=all&website=7&file=privacycoach.lang
And the verdict is, No Indic locales.  And also no Catalan, just Spanish.
Flags: needinfo?(pascalc)
(Assignee)

Comment 22

3 years ago
(In reply to Jenn Chaulk from comment #21)
> And the verdict is, No Indic locales.  And also no Catalan, just Spanish.

ok :) 

Note that we may have bonus locales if some of our localizers decide to translate the add-on for their language even if they are not in the list of locales we defined and finish in time for the deadline I announced (November 7). As an example, the zh-TW l10n lead will work on this project for Taiwanese users.
Flags: needinfo?(pascalc)
Jenn: for future reference, when you say "Spanish", which of the following locales (some or all) do you mean?

es-AR
es-MX
es-ES
es-US (which we don't explicitly support in-product, despite it being our 8th most popular install locale)

The product works in terms of locales, not geographic regions. Sometimes those things have a very close correlation (de), sometimes not ("US" -> LatAm Spanish dialects are spoken by 35M people, and plenty of other languages besides).

I see Pascal has assumed es-MX and es-ES, but we'll all have an easier time if we're working with the same concepts.
It is actually both es-mx and es-es, as we were looking at Spain and Mexico from the list of regions provided by Arcadio.  The last comment was specifically in regards to Spain... The question was whether we wanted just Spanish/es for Spain, or if we wanted Catalan/ca as well, and the verdict was just Spanish.  Sorry for any confusion.
Flags: needinfo?(jchaulk)
(Assignee)

Comment 25

3 years ago
Mark, would it be possible to automatically generate an xpi with locales as they get done so as that localizers can test their translation on a real device? I will provide the translations as pull requests to the repo.
Flags: needinfo?(mark.finkle)
(In reply to Pascal Chevrel:pascalc from comment #25)
> Mark, would it be possible to automatically generate an xpi with locales as
> they get done so as that localizers can test their translation on a real
> device? I will provide the translations as pull requests to the repo.

Automatically? I have no idea.
Manually? Yes.

Either Margaret or I could make new XPIs whenever you want.
Flags: needinfo?(mark.finkle)
The build script here is simple shell, so getting this on ci.mozilla.org should be straightforward.

I started that:

https://ci.mozilla.org/job/privacy-coach/
Pushes to the repo will now result in a new XPI being automatically built. See

https://ci.mozilla.org/job/privacy-coach/

in particular

https://ci.mozilla.org/job/privacy-coach/lastSuccessfulBuild/artifact/coach.xpi
(Assignee)

Comment 29

3 years ago
(In reply to Richard Newman [:rnewman] from comment #28)
> Pushes to the repo will now result in a new XPI being automatically built.
> See
> 
> https://ci.mozilla.org/job/privacy-coach/
> 
> in particular
> 
> https://ci.mozilla.org/job/privacy-coach/lastSuccessfulBuild/artifact/coach.
> xpi

Awesome, that's really useful for testing, thanks a lot Richard :)
(In reply to Pascal Chevrel:pascalc from comment #20)
> Localization is launched for the locales we are sure of, here is a dashboard
> to follow progress:
> https://l10n.mozilla-community.org/~pascalc/langchecker/
> ?locale=all&website=7&file=privacycoach.lang

Thanks, Kohei already translated and the confirmed with xpi builds for ja locale:
http://viewvc.svn.mozilla.org/vc/projects/l10n-misc/trunk/add-ons/ja/
Nominating to track Fennec since this is a N2R dependency.
tracking-fennec: --- → ?
tracking-fennec: ? → ---
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #31)
> Nominating to track Fennec since this is a N2R dependency.

Sorry for the pain the N2R stuff is causing you with regard to "tracking". We honestly didn't know how to track it either. Jumping straight to release defies all of our best practices and tooling. And here we are.
(Assignee)

Comment 33

3 years ago
As of today, we have 10 locales. There are 4 locales not done, it's possible we get one of two over the week end but I think it's safe to say that we will probably ship the add-on with these 10 locales already merged in the repository. 

Note that I will be on PTO this evening (18h GMT+2) until end of next week and probably won't have any internet access until Tuesday. flod knows how to use my script to populate and package the add-on with translations in case we have a late locale or translation updates needed.
(In reply to Pascal Chevrel:pascalc from comment #33)
> As of today, we have 10 locales. There are 4 locales not done, it's possible
> we get one of two over the week end but I think it's safe to say that we
> will probably ship the add-on with these 10 locales already merged in the
> repository. 

Amazing work! Thanks for diving into this. We certainly couldn't have done it without you and the localizers.

> Note that I will be on PTO this evening (18h GMT+2) until end of next week
> and probably won't have any internet access until Tuesday. flod knows how to
> use my script to populate and package the add-on with translations in case
> we have a late locale or translation updates needed.

Since it's an add-on, we can always release an update next week sometime to pick up any late locales that get finished.
Flags: needinfo?(deb)
Agree!  Many thanks Pascal!!  It's great we got as many locales as we did!  

The 10 we have are being posted to AMO today, and we're good to go!
I see these locales on AMO:

+cs
 de
 en-US
 es-ES
 es-MX
 fr
+it
 ja
 pl
 pt-BR
 ru
+sq
+zh-TW

so we're missing Indonesia (id) and Hungary (hu) from the list of target launch locales, but we picked up Czech, Italian, Albanian, and Chinese as extras.

Do we want to keep this bug open to track those two target locales, or are we done here?
Flags: needinfo?(pascalc)
Flags: needinfo?(deb)
(Assignee)

Comment 37

3 years ago
We can close this bug, Indonesian and Hungarian are locales we are currently lacking manpower for and even if we find new skilled localizers for these locales, we will need them to focus on our core products first.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(pascalc)
Resolution: --- → FIXED
Flags: needinfo?(deb)
You need to log in before you can comment on or make changes to this bug.