Fennec won't build with search activity disabled

REOPENED
Unassigned

Status

()

Firefox for Android
Build Config & IDE Support
--
critical
REOPENED
3 years ago
3 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Merge day is Monday. This needs fixing ASAP.

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2355161&repo=try

/builds/slave/try-and-0000000000000000000000/build/mobile/android/base/resources/layout/search_activity_main.xml:46: error: Error: No resource found that matches the given name (at 'contentDescription' with value '@string/search_pref_button_content_description').
/builds/slave/try-and-0000000000000000000000/build/mobile/android/base/resources/layout/search_suggestions_row.xml:21: error: Error: No resource found that matches the given name (at 'contentDescription' with value '@string/search_plus_content_description').
/builds/slave/try-and-0000000000000000000000/build/mobile/android/base/resources/layout/search_widget.xml:23: error: Error: No resource found that matches the given name (at 'contentDescription' with value '@string/search_widget_button_label').
/builds/slave/try-and-0000000000000000000000/build/mobile/android/base/resources/layout/search_widget.xml:32: error: Error: No resource found that matches the given name (at 'text' with value '@string/search_widget_button_label').
/builds/slave/try-and-0000000000000000000000/build/mobile/android/base/resources/xml/search_preferences.xml:6: error: Error: No resource found that matches the given name (at 'title' with value '@string/pref_clearHistory_title').
/builds/slave/try-and-0000000000000000000000/build/mobile/android/base/resources/xml/search_widget_info.xml:6: error: Error: No resource found that matches the given name (at 'label' with value '@string/search_widget_name').
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081249
Let's un-dupe this and use it to fix the build conditional.
Severity: blocker → critical
Status: RESOLVED → REOPENED
Component: General → Build Config & IDE Support
Hardware: ARM → All
Resolution: DUPLICATE → ---
Summary: Android builds are going to burn when Gecko 35 merges to Aurora → Fennec won't build with search activity disabled

Updated

3 years ago
Duplicate of this bug: 1081253
You need to log in before you can comment on or make changes to this bug.