Closed Bug 1081252 Opened 8 years ago Closed 7 years ago

Changing offers in have-local-offer and have-remote-offer states

Categories

(Core :: WebRTC: Signaling, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1072388

People

(Reporter: mt, Unassigned)

References

Details

JSEP supports the notion that a peer could change its mind about an offer and provide a completely different one.  The only restriction is the RFC 3264 one that requires that it be compatible with the currently stable state of the session.

This is bananas, it creates an epic level of complication to support some pretty marginal use cases.  However, in the interests of specification compliance - which we dearly love here at Mozilla - we should try to do this.
See Also: → 1081257
It seems to me that this is just syntactic sugar for a rollback followed by a SetLocal/SetRemote, right (with fewer success callbacks)? Once we have rollback, I think this ends up being easy.
Depends on: 1081257
Depends on: 952145
No longer depends on: 1081257
backlog: --- → webRTC+
Rank: 39
Priority: -- → P3
Yeah.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1072388
You need to log in before you can comment on or make changes to this bug.