Closed Bug 1081258 Opened 7 years ago Closed 7 years ago

Non-unified bustage in DOMCameraControlListener.cpp when building with MSVC2013

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: RyanVM, Assigned: benjamin)

Details

Attachments

(2 files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=49977688&tree=Try

DOMCameraControlListener.cpp

c:\tools\vs2013\vc\include\math.h(106) : error C2220: warning treated as error - no 'object' file generated

c:\tools\vs2013\vc\include\math.h(106) : warning C4005: 'NAN' : macro redefinition

        c:\builds\moz2_slave\try-w32-0000000000000000000000\build\dom\camera\CameraCommon.h(19) : see previous definition of 'NAN'

c:/builds/moz2_slave/try-w32-0000000000000000000000/build/config/rules.mk:948: recipe for target 'DOMCameraControlListener.obj' failed
mozmake.exe[5]: *** [DOMCameraControlListener.obj] Error 2
Attached patch 1081258-NANSplinter Review
Untested, but this ought to work.
Assignee: nobody → benjamin
Status: NEW → ASSIGNED
Attachment #8503348 - Flags: review?(dmajor)
Comment on attachment 8503348 [details] [diff] [review]
1081258-NAN

Review of attachment 8503348 [details] [diff] [review]:
-----------------------------------------------------------------

Can we just get rid of it? I can't find any uses of NAN remaining after these refactorings:

http://dxr.mozilla.org/mozilla-central/search?q=regexp%3A\WNAN\W&case=true&redirect=true
http://hg.mozilla.org/mozilla-central/rev/e93e96ed8a5a
http://hg.mozilla.org/mozilla-central/rev/6ae8548ce144
http://hg.mozilla.org/mozilla-central/rev/c9f413c5774e
Attachment #8503348 - Flags: review?(dmajor) → review+
(And good catch, Ryan. This must have been a recent regression since I had a green 2013 Bn on Wednesday: https://tbpl.mozilla.org/?tree=Try&rev=c8a14d829945)
Attached patch 1081258-NANSplinter Review
Yes, that works too.
Attachment #8503367 - Flags: review?(mhabicher)
Comment on attachment 8503367 [details] [diff] [review]
1081258-NAN

Review of attachment 8503367 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8503367 - Flags: review?(mhabicher) → review+
I verified that the patch builds and pushed it:
https://hg.mozilla.org/integration/mozilla-inbound/rev/43bd6e46c62c
https://hg.mozilla.org/mozilla-central/rev/43bd6e46c62c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.