Double-click-and-hold (1.5 clicks) shouldn't open context menu

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: David Hyatt)

Tracking

Trunk
mozilla1.1alpha
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build: 2001103108, Mac OS 9.1

To reproduce:
1.  Rapidly mouse down, mouse up, and mouse down anywhere, e.g. in a Web page
    to begin selection of some text in word-by-word mode.
2.  Wait half a second.

What happens:
*   The context menu opens.

What should happen:
*   Nothing.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 2

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".
Well, the behaviour is still the same as in comment #0 with Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; de-AT; rv:1.8a1) Gecko/20040520, but I don't
know what is wrong with that :-\

Comment 4

14 years ago
seems resanable... to say that this exist for 10.x as well... as the behavior
doesn't exist in the Finder but in Firefox and Seamonkey's... so moving to os
x... but what should the expected behavior be? I've come to expect this.

So moving for now... action later?
OS: Mac System 9.x → MacOS X
(Reporter)

Comment 5

14 years ago
Expected behavior, as I wrote in comment 0, is to begin selection of text in word-
by-word mode. Y'know, just like selecting text works in every other Windows/Mac app.

Comment 6

14 years ago
I think it might be simpler then to just reduce the concept of this bug to
click-and hold then... would you agree with that... as that shouldn't be
expected behavior... I only ask what the expected behavior is mostly out
repetitive conditioning I've come to expect this... so at first I was a little
confusead :)
(Reporter)

Comment 7

14 years ago
No, click-and-hold should begin selection of text in character-by-character mode. 
And it already does, so that's not a bug. This bug is not about click-and-hold.

Comment 8

14 years ago
hmmm... sometimes when I click and hold I do get a context menu and not
character-by-character mode... not often but I do... thats why I was wonder.

Comment 9

12 years ago
dead bug?
Yeah, dead now that click-and-hold doesn't open context menus.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.