bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Gallery] Not all videos are appearing in the gallery

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Gallery
--
enhancement
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: AdamA, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.0-flame-test-run-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8503386 [details]
logcat

Description:
Videos that users make with the Flame camera appear in the gallery, but any video that the user adds from a different source or places on the memory card directly will not appear in the gallery. These videos appear in the video app. this may confuse users seeing videos in the gallery app but not the ones that they added.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141010000201
2) Add a video to the memory card through USB
3) Take a video using the device camera
4) Open up the gallery and view amount of videos
5) Observe the amount of videos in the video app
  
Actual:
There is a inconsistency between the amount of videos in the gallery and video app

Expected: 
It is expected that the videos are consistent between the gallery and video app
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Full Flash)
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 100%
See attached: video clip(http://youtu.be/4Tw5rW2BfDM), logcat
(Reporter)

Comment 1

4 years ago
This issue occurs in 2.2 Flame and 2.0 Flame.

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2
BuildID: 20141010040202
Gaia: 1036b544b7e102592bd9fab95cd9317329ac1293
Gecko: 50b689feab5f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Flame 2.0 KK (319mb) (Full Flash)

Environmental Variables:
Device: Flame 2.0
Build ID: 20141010000201
Gaia: 9791940d5093c37336dcd85f7e66e9a8445a218e
Gecko: 00d3c843aeec
Version: 32.0 (2.0)
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Result:
There is an inconsistency between the amount of videos in the gallery and video app
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Not nominating this as a blocker. The user can still find the videos that are put on the phone, they are just in the video app and are not found in the gallery app.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:
This issue is still happening, and although it's not a regression and has clear workaround, it's a broken functionality for Gallery app, nominating for 2.5.
blocking-b2g: --- → 2.5?
Issue also occurs on Flame 2.5 and Aries KK. I transferred videos from a laptop to those two devices using bluetooth, and they would appear in the Video app, but not Gallery.

Flame 2.5

Actual Result:

Videos transferred to the device appear in Video, but not Gallery.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150729030209
Gaia: 21256d7665f972255d198f8af81a8df4bd0e0fc4
Gecko: 2ee9895e032c
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Aries KK

Actual Result:

Videos transferred to the device appear in Video, but not Gallery.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150727151800
Gaia: 4e3e21a4ba3f188b45623ee2297f21d0791f8667
Gecko: 21ca97268bae
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Comment 5

3 years ago
[Tracking Requested - why for this release]:
Severity: normal → enhancement
blocking-b2g: 2.5? → ---
tracking-b2g: --- → backlog

Comment 6

5 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.