[Dialer][Ringtone] Ringtone only plays once, does not loop, when receiving a call and will not ring on subsequent calls.

RESOLVED DUPLICATE of bug 1076975

Status

()

defect
RESOLVED DUPLICATE of bug 1076975
5 years ago
5 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Posted file logcat-Ringtone.txt
Description:
When receiving a call, the phone will only play the ringtone once, and will not loop it.

If the ringtone is allowed to play all the way through, the ringtone will not play at all on any subsequently received calls until the phone is restarted or the ringtone is changed.

Changing the ringtone (even back to the default ringtone) will temporarily fix this issue, causing the ringtone to loop properly, and continue to ring in subsequent calls.

Restarting the device, even with a new ringtone, will reset the issue, again allowing the ringtone to play only once, and not play on any subsequent calls.

Repro Steps:
1) Update a Flame device to BuildID: 20141010040202
2) Progress through the FTU and make sure the device is ready to receive calls.
3) Call the DUT from another phone.
4) Allow the DUT to continue ringing for at least one loop of the entire ringtone.
  
Actual:
Ringtone only plays once, does not loop. Ringtone does not sound at all on subsequent calls.
  
Expected: 
Ringtone continues to loop as long as the device is ringing. Ringtone sounds on all subsequent calls.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141010040202 (Full Flash)
Gaia: 1036b544b7e102592bd9fab95cd9317329ac1293
Gecko: 50b689feab5f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Note: This occurs on both v180 and v184 firmware.

Repro frequency: 7/7
See attached: logcat

---------------------------------------------

This issue does NOT occur on Flame 2.1.
Ringtone loops appropriately when receiving a call.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Functional regression of a core feature, phone is expected to keep ringing.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
I've noticed this on my Flame too, does it also reproduce on other devices?
QA Contact: pcheng
mozilla-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20140926154139
Gaia: e30d373eb5ed0514bce08a3b3d80d71b05a4dc32
Gecko: 627e848b2bf3
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20140926162338
Gaia: e30d373eb5ed0514bce08a3b3d80d71b05a4dc32
Gecko: 8892214038df
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=627e848b2bf3&tochange=8892214038df

Caused by Bug 994190.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Caused by Bug 994190 - can you take a look Ben?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(bent.mozilla)
I think this might be related to bug 1080298 and the changes to Blobs in bug 994190.
triage: regression
blocking-b2g: 2.2? → 2.2+
Component: Gaia::Dialer → DOM: IndexedDB
Product: Firefox OS → Core
Can you please test again now that bug 1079546 has landed?
Flags: needinfo?(bent.mozilla)
(In reply to ben turner [:bent] (use the needinfo? flag!) from comment #7)
> Can you please test again now that bug 1079546 has landed?

This issue is NOT fixed on latest master build. Not only does this issue continue to occur (ringtone does not loop), the device also exhibits bug 1077331 whereas the device won't stop vibrating after ringtone plays once.

Tested on:
Device: Flame (shallow flash, 319MB mem)
BuildID: 20141017073248
Gaia: 1daf2dadcd0d554c733661a4c0be1b82001e9da0
Gecko: 51892b39597a
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Hrm, would you mind attaching an updated logcat?
Flags: needinfo?(pcheng)
Logcat attached. Tested on the same environment as comment 9.
Flags: needinfo?(pcheng)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
So the problem here is that we have a same process blob over IPC (from IndexedDB) and its stream is not seekable because it has an mFd but no mFile to recreate it from once we read to EOF.
This is fixed by the patch in bug 1076975
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1076975
You need to log in before you can comment on or make changes to this bug.