Closed Bug 1081349 Opened 7 years ago Closed 7 years ago

Intermittent leftA-widthN-rightA.html?margin_parent | image comparison (==), max difference: 255, number of differing pixels: 1000

Categories

(Core :: Layout, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- unaffected
firefox35 --- fixed
firefox36 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: nical)

References

Details

(Keywords: intermittent-failure, regression)

Attachments

(3 files)

Attached image test screenshot
https://treeherder.mozilla.org/ui/logviewer.html#?job_id=2917829&repo=mozilla-inbound

builder 	b2g_emulator_vm mozilla-inbound opt test reftest-14
buildid 	20141010100308
builduid 	e4bf2cf8d2384c19a7d647240662989b
results 	warnings (1)
revision 	dc05ab9ff12cb81d7e2bd88494062fe9ad1c464d
slave 		tst-linux64-spot-064
starttime 	Fri Oct 10 2014 13:30:23 GMT-0400 (Eastern Standard Time)

11:14:02 INFO - REFTEST TEST-START | http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:02 INFO - REFTEST TEST-LOAD | http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent | 404 / 575 (70%)
11:14:02 INFO - REFTEST TEST-LOAD | http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA-ref.html?margin_parent | 404 / 575 (70%)
11:14:02 INFO - REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent | image comparison (==), max difference: 255, number of differing pixels: 1000
11:14:02 INFO - REFTEST IMAGE 1 (TEST): 
11:14:02 INFO - REFTEST IMAGE 2 (REFERENCE): 
11:14:02 INFO - REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
11:14:02 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
11:14:02 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
11:14:02 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
11:14:02 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for MozAfterPaint
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 122 108 132 208
11:14:02 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
11:14:02 INFO - REFTEST INFO | Saved log: DoDrawWindow 122,108,10,100
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:02 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 132 108 142 208
11:14:03 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
11:14:03 INFO - REFTEST INFO | Saved log: DoDrawWindow 132,108,10,100
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 142 108 162 208
11:14:03 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
11:14:03 INFO - REFTEST INFO | Saved log: DoDrawWindow 142,108,20,100
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 162 108 172 208
11:14:03 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
11:14:03 INFO - REFTEST INFO | Saved log: DoDrawWindow 162,108,10,100
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 172 108 182 208
11:14:03 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
11:14:03 INFO - REFTEST INFO | Saved log: DoDrawWindow 172,108,10,100
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:03 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 182 108 212 208
11:14:41 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
11:14:41 INFO - REFTEST INFO | Saved log: DoDrawWindow 182,108,30,100
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] AttrModifiedListener fired
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_SPELL_CHECKS
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FINISH
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: Completed
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_COMPLETED
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_COMPLETED
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
11:14:41 INFO - REFTEST INFO | Saved log: RecordResult fired
11:14:41 INFO - REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA-ref.html?margin_parent
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
11:14:41 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
11:14:41 INFO - REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
11:14:41 INFO - REFTEST INFO | Saved log: [CONTENT] RecordResult fired
11:14:41 INFO - REFTEST INFO | Saved log: RecordResult fired
11:14:41 INFO - REFTEST INFO | Loading a blank page
11:14:41 INFO - REFTEST TEST-END | http://10.0.2.2:8888/tests/layout/reftests/position-dynamic-changes/horizontal/leftA-widthN-rightA.html?margin_parent
Attached image reference screenshot
This is frequent and widespread (as the TBPLbot comments indicate). Any help in isolating the cause would be greatly appreciated.
Flags: needinfo?(mstange)
Flags: needinfo?(mats)
Flags: needinfo?(dholbert)
Flags: needinfo?(dbaron)
Looks like an invalidation/graphics bug of some sort.  Many of the test
screenshots look the same, so that might give a clue about the nature
of the bug.
Flags: needinfo?(mats)
Blocks: 1081962
Blocks: 1081927
Blocks: 1082280
Blocks: 1081893
Blocks: 1082481
Blocks: 1082571
roc, matt, does the attached screenshots give you any clue about what the
general problem might be? (the black areas shouldn't be there)
Flags: needinfo?(roc)
Flags: needinfo?(matt.woodrow)
Keywords: regression
The recent spike in failures here seems to indicate it's a recent regression.
Ryan, would it be possible to pinpoint roughly when this regression started?
Flags: needinfo?(ryanvm)
"Maybe" assuming it's a code change and not something in the harness or on AWS or something.
Flags: needinfo?(ryanvm)
Or "someone added/removed reftests and changed the chunking around"
This was probably caused by bug 1071769, which landed on Oct 10 (the day this bug was filed). The first try push in that bug also showed the same reftest failure.
Blocks: 1071769
Flags: needinfo?(mstange)
Assignee: nobody → nical.bugzilla
Flags: needinfo?(roc)
Flags: needinfo?(matt.woodrow)
Flags: needinfo?(dholbert)
Flags: needinfo?(dbaron)
Yeah, looks like a tiling problem, probably copying front buffer to back buffer.

Nical, disabling the 'fast path' where we re-use the front buffer might change the frequency of this in a useful way.
Blocks: 1083150
Any news here? I'm leaning towards backing out if there isn't a fix coming any time soon.
Flags: needinfo?(nical.bugzilla)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #39)
> Any news here? I'm leaning towards backing out if there isn't a fix coming
> any time soon.

I am actively looking at it (when not busy with the OMTC Windows craziness). I don't have an ETA since I haven't figured out exactly what's causing this yet.
Flags: needinfo?(nical.bugzilla)
The problem is not caused by a failure to allocate (or by mixing gralloc and shmem texture in the same tile buffer). I expect it's an invalidation tracking bug (still looking)
No longer blocks: 1081927
Duplicate of this bug: 1081927
Duplicate of this bug: 1082481
No longer blocks: 1083150
Duplicate of this bug: 1083150
No longer blocks: 1082481
No longer blocks: 1081893
Duplicate of this bug: 1081893
No longer blocks: 1082280
Duplicate of this bug: 1082280
No longer blocks: 1082571
Duplicate of this bug: 1082571
Duplicate of this bug: 1085259
Duplicate of this bug: 1086173
Duplicate of this bug: 1087209
Duplicate of this bug: 1093651
No longer blocks: 1081962
Bug 1071769 backed out.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.