l10n packager error since new file structure

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Nomis101, Unassigned)

Tracking

({regression})

Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird34 fixed, thunderbird35 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
Since the OS X builds switched to the new file structure I'm seeing the following error if I try to make the dmg from a localized build:
$ make -C obj-x86_64-apple-darwin14.0.0/mail/installer
...
		package-manifest ../../dist ../../dist/thunderbird \
		--non-resource defaults/messenger/mailViews.dat
Error: /Volumes/Developer/comm-central/obj-x86_64-apple-darwin14.0.0/mail/installer/package-manifest:26: Missing file(s): Thunderbird.app/Contents/Resources/en.lproj/*

I don't see this problem for non-localized en-US builds.
Keywords: regression
Reporter

Comment 1

5 years ago
Posted patch PatchSplinter Review
This is a port of the patch from Bug 1084578.
Attachment #8508503 - Flags: review?(mconley)
Comment on attachment 8508503 [details] [diff] [review]
Patch

Review of attachment 8508503 [details] [diff] [review]:
-----------------------------------------------------------------

This is correct (but is not enough to fix SeaMonkey's Bug 1087089 if I port it there sadly). r=me as a TB build system peer.

Likely necessary to uplift all the way to beta though, so please request approval.
Attachment #8508503 - Flags: review?(mconley) → review+
Reporter

Updated

5 years ago
Keywords: checkin-needed
Reporter

Comment 3

5 years ago
Comment on attachment 8508503 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): 1074002
User impact if declined: Packing error for l10n builds (= no l10n builds)
Testing completed (on c-c, etc.): See Bug 1084578
Risk to taking this patch (and alternatives if risky): No real risk
Attachment #8508503 - Flags: approval-comm-beta?
Reporter

Comment 4

5 years ago
Comment on attachment 8508503 [details] [diff] [review]
Patch

If we need beta, we will need aurora too.

[Approval Request Comment]
Regression caused by (bug #): 1074002
User impact if declined: Packing error for l10n builds (= no l10n builds)
Testing completed (on c-c, etc.): See Bug 1084578
Risk to taking this patch (and alternatives if risky): No real risk
Attachment #8508503 - Flags: approval-comm-aurora?
Landed on c-c: https://hg.mozilla.org/comm-central/rev/9012461955e4

Still waiting on the approval flags.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attachment #8508503 - Flags: approval-comm-beta?
Attachment #8508503 - Flags: approval-comm-beta+
Attachment #8508503 - Flags: approval-comm-aurora?
Attachment #8508503 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.