[Contacts] When stretching out a manually created contacts photo flickering occurs

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: rmitchell, Unassigned)

Tracking

34 Branch
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-flame-test-run-3], URL)

Attachments

(1 attachment)

47.67 KB, text/plain
Details
(Reporter)

Description

4 years ago
Created attachment 8503520 [details]
Log cat

Description:when stretching out a manually created contacts photo flickering occurs and the photo will constantly resize for a few moments.

Repro Steps:
1) Update a Flame to 20141010000201
2) Create a contact with a photo
3) In contacts app tap created contact 
4) stretch out the photo to see whole photo and with second finger swipe another direction 

Actual:
flickering occurs   


Expected:
flickering does not occurs   

Environmental Variables:
Device: Flame 2.1 KK (319mb) (Full Flash)
Build ID: 20141010000201
Gaia: d71f8804d7229f4b354259d5d8543c25b4796064
Gecko: 7fa82c9acdf2
Version: 34.0a2 Flame 2.1 KK (319mb)
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency:100%
See attached: logcat and Video: https://www.youtube.com/watch?v=MGSahFeuHMU
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
Issue does not occur on Flame 2.2 Master KK (319mb) (Full Flash), Flame 2.0 KK (319mb) (Full Flash)

when stretching out a manually created contacts photo flickering occurs

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2
BuildID: 20141010040202
Gaia: 1036b544b7e102592bd9fab95cd9317329ac1293
Gecko: 50b689feab5f
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Flame 2.0 KK (319mb) (Full Flash)

Environmental Variables:
Device: Flame 2.0
Build ID: 20141010000201
Gaia: 9791940d5093c37336dcd85f7e66e9a8445a218e
Gecko: 00d3c843aeec
Version: 32.0 (2.0)
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
I think the video is not the correct one, or at least I cannot see the mentioned effect on it.
(Reporter)

Comment 3

4 years ago
yes the name on the video was wrong, here is the correct video https://www.youtube.com/watch?v=itGfQ5sh1Y8
Not blocking on this issue, as the user would have to try to scroll in 2 directions at once
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Component: Gaia::Contacts → Panning and Zooming
Product: Firefox OS → Core
Version: unspecified → 34 Branch
I don't think this is an APZ issue. The "revealing" of the photo is implemented in Gaia (I assume by listening for touch events), and the video shows that the flickering is happening because the photo is getting revealed more/less. Honestly to me it looks like flaky hardware sending touch events when it shouldn't be.

:RJ, can you confirm what you said in comment 1 that this does NOT occur on 2.2? The status flags on this bug contradict that, so something is wrong. If this does NOT occur on 2.2 and it's not blocking for 2.1 then there's nothing to do here so resolving WFM.

If your comment 1 was a typo, and you WERE able to reproduce it on 2.2, please reopen, and also please check to see if it happens on multiple devices? I cannot reproduce this on 2.2 so I'm strongly suspecting bad touch events being generated by the hardware.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(rmitchell)
(Reporter)

Comment 6

4 years ago
Hello, Kartikaya

It seems as of today’s 2.2 build, issue no longer occurs.

Here is the environmental variables I used 

Flame 2.2

Device: Flame 2.2 Master KK (319mb) (Full Flash)
BuildID: 20141017040208
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 36.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(rmitchell)
Ok, thanks for confirming. I guess it doesn't matter if it's still happening on 2.1 or 2.0 since it's not blocking.
You need to log in before you can comment on or make changes to this bug.