Closed Bug 1081467 Opened 10 years ago Closed 9 years ago

[e10s] 'Print Edit' extension does not work with e10s

Categories

(Firefox :: Extension Compatibility, defect)

35 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
e10s + ---

People

(Reporter: dw-dev, Unassigned)

References

Details

      No description provided.
Print Edit fails immediately with the error: "e10s printing is not implemented yet. Bug 927188.".
Summary: Print Edit add-on does not work at all with e10s → [e10s] 'Print Edit' extension does not work with e10s
https://addons.mozilla.org/en-US/firefox/addon/print-edit
Blocks: e10s-addons
Status: UNCONFIRMED → NEW
tracking-e10s: --- → +
Ever confirmed: true
From the developer, here is the current status:

recently started updating when print functionality became available in Firefox Nightly – substantial update required
Depends on: 927188
Print Edit was first updated to work in e10s windows in Version 13.0 (2014-12-02), which worked with Nightly 36.0a1.  Since then, Print Edit has been updated regularly to keep in step with the e10s printing/previewing changes, and also to fix bugs and implement new features.

Following the completion of the work to implement the e10s printing/previewing functionality (bugs 1088070 & 1136855), Print Edit has been updated to Version 15.2. This version is fully compatible with the latest e10s printing/previewing functionality in Nightly 39.0a1 and any workarounds that are no longer necessary have been removed.

Print Edit 15.2 was released today and supports all versions of Firefox from 4.0 to 39.0a1.

As far as I am concerned, this bug can now be closed.
Thanks!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.