RESOLVED DUPLICATE of bug 1125445

Status

()

Core
Canvas: WebGL
RESOLVED DUPLICATE of bug 1125445
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: jgilbert)

Tracking

({regression})

35 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox34 unaffected, firefox35+ wontfix, firefox36- affected, firefox37 affected)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8503585 [details]
screenshot

[Tracking Requested - why for this release]:

Reported on http://forums.mozillazine.org/viewtopic.php?p=13814123#p13814123


STR
1. Open http://madebyevan.com/webgl-water/

Actual Results:
Nightly35.0a1 doesn't render it correctly.
See attached screenshot.

Expected Results:
Render like Aurora34.0a2 and Chrome38
(Reporter)

Comment 1

3 years ago
In local build 
Last Good: 45472bfa3f16
First Bad: e17f9996e092

Regressed by:
  e17f9996e092	Jeff Gilbert — Bug 1048108 - Workaround ANGLE not having no-alpha surfaces. - r=kamidphish
Jeff - can you take a look at this and see if you can do a backout or forward fix for this regression?
status-firefox36: --- → affected
tracking-firefox35: ? → +
tracking-firefox36: --- → +
Flags: needinfo?(jgilbert)
(Reporter)

Comment 3

3 years ago
Please ignore comment #1
(Reporter)

Comment 4

3 years ago
Oops
Sorry, please ignore Comment #3.

Comment #1 is correct.
Jeff - We're almost out of time on beta. Do you still intend to work on this? If not, bug 1048108 is going to ship in 34.
(Assignee)

Comment 6

3 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #5)
> Jeff - We're almost out of time on beta. Do you still intend to work on
> this? If not, bug 1048108 is going to ship in 34.

I'll see what I can do.
Flags: needinfo?(jgilbert)
(Assignee)

Updated

3 years ago
Assignee: nobody → jgilbert
Jeff - I need to ping you on this one as we're going to build with 34 beta9 (the last scheduled beta) Thursday. Any progress on this bug?
Flags: needinfo?(jgilbert)
(Assignee)

Comment 8

3 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #7)
> Jeff - I need to ping you on this one as we're going to build with 34 beta9
> (the last scheduled beta) Thursday. Any progress on this bug?

Nothing new yet. Still trying to figure out what it is.
Flags: needinfo?(jgilbert)
(Assignee)

Comment 9

3 years ago
Created attachment 8521956 [details]
gl command dump
Beta10 goes to build today and our final beta will now be Beta11, which will go to build on Thursday. Depending on whether Jeff is able to find a fix and the risk of accepting the fix, we may or may not be able to fix this bug in 34.
(Assignee)

Comment 11

3 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #10)
> Beta10 goes to build today and our final beta will now be Beta11, which will
> go to build on Thursday. Depending on whether Jeff is able to find a fix and
> the risk of accepting the fix, we may or may not be able to fix this bug in
> 34.

Thanks for the update. I think I'm most of the way there.
We're going to build with the final beta11 in ~1.5 hours. I take it this fix isn't ready and that we'll be shipping this issue in 34. I don't think this is stop ship so we'll need to live with this for at least one cycle.
(Assignee)

Comment 13

3 years ago
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #12)
> We're going to build with the final beta11 in ~1.5 hours. I take it this fix
> isn't ready and that we'll be shipping this issue in 34. I don't think this
> is stop ship so we'll need to live with this for at least one cycle.

Alright, just go without it.
Hey Jeff - anything new that could be considered for FF35?  We have one more beta on Mon Dec 29th.
Flags: needinfo?(jgilbert)
(Assignee)

Comment 15

3 years ago
(In reply to Lukas Blakk [:lsblakk] use ?needinfo from comment #14)
> Hey Jeff - anything new that could be considered for FF35?  We have one more
> beta on Mon Dec 29th.

No.
Flags: needinfo?(jgilbert)
Wontfixing for 35 in that case, and also removing tracking as this - like bug 1089140 - doesn't appear to have large impact and we can take followup fixes on a per-case basis for uplift as they are available.
status-firefox35: affected → wontfix
status-firefox37: --- → affected
tracking-firefox36: + → -
This seems to have gotten worse - see bug 1118284.
See Also: → bug 1118284
(Reporter)

Comment 18

3 years ago
It works if alpha contextAttributes has been explicitly defined when initialize webgl context.

"lightgl.js"

   create: function(options) {
     options = options || {};
     var canvas = document.createElement('canvas');
     canvas.width = 800;
     canvas.height = 600;
+    try {
+      options.alpha = true;
+    }  catch (e) {}
     if (!('alpha' in options)) options.alpha = false;
     try { gl = canvas.getContext('webgl', options); } catch (e) {}
     try { gl = gl || canvas.getContext('experimental-webgl', options); } catch (e) {}
     if (!gl) throw new Error('WebGL not supported');
Does setting a preference webgl.default-no-alpha to true change the behaviour here?

Comment 20

3 years ago
(In reply to Milan Sreckovic [:milan] from comment #19)
> Does setting a preference webgl.default-no-alpha to true change the
> behaviour here?

No (tested with 35 & 38).

Comment 21

3 years ago
I tested with the latest Nightly, it's fixed by bug 1125445, let's close it as dupe.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125445
You need to log in before you can comment on or make changes to this bug.