Disk cache update with pref "once per session" does not work

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: bugzilla.spam2, Unassigned)

Tracking

SeaMonkey 2.30 Branch
All
Windows

SeaMonkey Tracking Flags

(seamonkey2.30?)

Details

(Reporter)

Description

4 years ago
I have set the pref Advanced/Cache/Compare the page... to "Once per session".

After visiting a website, closing SeaMonkey, restarting SeaMonkey and revisiting the same website after it changed the new content is not displayed but the old one from the disk cache.

Comment 1

3 years ago
I will do a test now.

Comment 2

3 years ago
And again, now with "Restore Session"

Comment 3

3 years ago
And now again to be sure

Comment 4

3 years ago
More or less REPRODUCIBLE with  SeaMonkey German 2.39 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0 from official download area)  Gecko/20100101  Firefox/42.0  Build 20151103191810  (Classic Theme) on German WIN7 64bit:

0. Preparations - amend preferences if necessary  in Menu 'Edit → ':
   'Advanced → Cache': administration by SeaMonkey, Update once per session
   'Appearance': Launch with Browser, restore last session
1. Open this page in Browser and remember how it looks
2. Quit SeaMonkey
3. 'Launch FF and add a comment here → Quit FF'
4. Launch SeaMonekey
   » Browser opens, show this page
   Expected: Comment created with FF shown
   Bug:New Comment from Step 3 not shown

Additional Information
a) Click on Navigation Bar → Reload Current Page heals the problem, new comment will
   appear.
OS: Windows 8.1 → Windows
Priority: P5 → --
Hardware: x86_64 → All

Comment 5

3 years ago
b) Rightclick "Bug 1081518" (in bug report Header) → open in new Window'
   will show the missing contents after step 4

Comment 6

3 years ago
c) after my test for (b) (I typed Comment 5 in newly opened Window) I
   switched back to old window, where this report still was shown 
   unhanged. Click on "Bug 1081518" (in bug report Header) newly opened the 
   page in the same TAB, now with complete contents.
   So I currently I see a problem "Once per session" update should be done 
   when open page the first time after having launched SeaMonkey?

Comment 7

3 years ago
d) After I wrote my Comment 6 in FF In SM Browser I click on "Bug 1081518" 
  (in Bug report Heading): Page opens with new contents from WEB, not with 
   old contents from Cache
  I need no learn more about Cache
c): Not a bug: Preference from Step 0 - Appearance is "Restore Last Session",
    not "open all web pages from last session, but with updated contents

@reporter:
What exactly is your problem? Please cite some Help contents, specifications or similar defining expectged behavior and contribute a step by step instruction how to reproduce behavior different from that definition.
Flags: needinfo?(bugzilla.spam2)
(Reporter)

Comment 8

3 years ago
This bug was reported 1,5 years ago. I don't know anymore what happened back then. As cache is shared code there may have been changes in the backend that solved this.
Closing as invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bugzilla.spam2)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.