[System]The date icon will disappear from the status bar when the device has twelve icons or more appearing in the status bar

RESOLVED INVALID

Status

Firefox OS
Gaia::System
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: cnelson, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8503675 [details]
2014-10-11-14-23-19.png

When the device has up twelve icons or more appearing in the status bar, the date icon will disappear from the status bar.  The user will need to pull down the notifications tab in order to see the date icon in the status bar.  Once the user pulls down the notifications tab while twelve or more icons are present within the status bar, the user will see the date icon disappear and reappear.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141010000201
2) Turn on Bluetooth, set an alarm, set ring volume to vibrate or off, turn on usb tethering, turn on NFC, connect to wifi, turn on Geolocation, plug in headphones, and download a file.
3) Pull down or open the notifications tab.
4) Notice the date icon will disappear from the status bar.
  
Actual:
The date icon disappears from the status bar when the device has twelve or more icons present in the status bar.
  
Expected: 
The date icon will never disappear from the status bar in the notifications tab.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20141010000201
Gaia: bc8eb493311c58f1f311a56b8b645b52bfbd2f71
Gecko: 72c13d8631ff
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: For Geolocation icon to appear, the user must download and launch here maps application.
  
Repro frequency: 100%
See attached: screenshot ,logcat
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
This issue does occur on Flame 2.2 Master KK (319mb) (Full Flash), and Flame 2.0 KK (319mb) (Full Flash).

The date icon disappears from the status bar when the device has twelve or more icons present in the status bar.

Flame 2.2 Master KK (319mb) (Full Flash)

Device: Flame 2.2 Master
BuildID: 20141011040204
Gaia: 95f580a1522ffd0f09302372b78200dab9b6f322
Gecko: 3f6a51950eb5
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

On Flame 2.0, this issue is appearing differently as the date icon will become overlapped by other icons.  Refer to bug 1071512.

Flame 2.0 KK (319mb) (Full Flash)

Device: Flame 2.0
BuildID: 20141011000202
Gaia: 6effca669c5baaf6cd7a63c91b71a02c6bd953b3
Gecko: 54ec9cb26b59
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
(Reporter)

Updated

4 years ago
Blocks: 1071512
(Reporter)

Comment 2

4 years ago
Created attachment 8503676 [details]
logcatDateicon.txt
This is an intended behaviour introduced by Bug 1071512.
See https://bugzilla.mozilla.org/show_bug.cgi?id=1071512#c6 for more details

Now, the date is treated like any other icon but has the lowest priority possible. So if it doesn't fit, it just disappears from the status bar.
Assignee: nobody → gmarty
Assignee: gmarty → nobody
See comment 3.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
You need to log in before you can comment on or make changes to this bug.