Closed Bug 1081567 (breton-keyboard) Opened 8 years ago Closed 5 years ago

[Keyboard] adding Breton layout

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: taz, Unassigned)

References

Details

Attachments

(1 file, 1 obsolete file)

46 bytes, text/x-github-pull-request
Details | Review
The C'HWERTY keyboard layout is the bretons keyboard equivalent for the bretons language.
Attached file patch for keyboard (obsolete) —
Depends on: 1067479
Attached file good patch
Attachment #8503681 - Attachment is obsolete: true
Attachment #8503729 - Flags: review?(janjongboom)
OS: Linux → All
Hardware: x86 → All
Hi Dattaz,

Thanks for the patch.
Could you update the PR to bind the layout to the br locale here please? https://github.com/mozilla-b2g/gaia/blob/master/build/config/keyboard-layouts.json

Also, I don't think we can set autoCorrectLanguage since we don't have Breton dictionary yet.
And autoCorrectPunctuation is mostly specific to French, it's been added in bug 808740 to match French typographic rules, not sure it's relevant for br locale (I don't know about their rules, though.)

CC'ing Breton team members, in case they want to use other layouts for Breton, if they need to. For instance, Basque is using “eu, es, fr, en” layouts. “eu” is the one used by default.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hi!

Could you add the "fr" and "en" layouts ?
The "br" layout would be the one used by default and the "fr" and "en" would be available.

We have an Hunspell dictionary here :
http://hg.mozilla.org/releases/l10n/mozilla-aurora/br/file/default/extensions/spellcheck/hunspell
Maybe it can help ?
I have made the change
(In reply to Michel Nédélec from comment #4)
> Hi!
> 
> Could you add the "fr" and "en" layouts ?
> The "br" layout would be the one used by default and the "fr" and "en" would
> be available.
> 
> We have an Hunspell dictionary here :
> http://hg.mozilla.org/releases/l10n/mozilla-aurora/br/file/default/
> extensions/spellcheck/hunspell
> Maybe it can help ?

Hi, thanks for the feedback, Michel! It will probably help, yes. I filled bug 1081716 for autocorrect in br.
Comment on attachment 8503729 [details] [review]
good patch

Stealing the review.
Attachment #8503729 - Flags: review?(janjongboom) → review?(rlu)
Comment on attachment 8503729 [details] [review]
good patch

I'll clear the review first since this patch seems not complete:
 1. The composite key like C'H cannot fit into our current UI, one way to workaround this (not a perfect way) is to add special CSS rules to resize these composite keys.

 2. The uppercase switching for these composite keys are not functional.
    That is when you press [shift] key and then type them, the keyboard would still output lowercase chars.
    You could check 'upperCase' field in el.js to see if that works.
    (I am not sure that could work for composite key, so please help give a try.)

--
Please flag me again for review for the next round.
Thank you!
Attachment #8503729 - Flags: review?(rlu)
Depends on: 1112183
Alias: breton-keyboard
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.