Closed Bug 1081680 Opened 7 years ago Closed 7 years ago

Adding letters ch and c'h for breton language

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1081567

People

(Reporter: jamybzh, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

Hi, it is possible to add letters in Fira font for breton language, we need letters ch (Ch in uppercase) and c'h (C'h in uppercase). 
for more information see 
http://www.evertype.com/alphabets/breton.pdf 

and here for an image of the keyboard 
http://www.servijer.net/skeud/klavierbreton.png

Thanks
Component: Gaia::Keyboard → Gaia
Hi,

This definitely needs to be fixed, thanks for filing this bug.
Since this is kind of the same issue as for bug 999083, NI'ing :patryk here as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(padamczyk)
:tchevalier, please needsinfo me on any future Fira bugs. Since Fira updates are aligned with Firefox OS releases we will likely address this in the next release of the OS: v.2.2.
Assignee: nobody → padamczyk
Flags: needinfo?(padamczyk)
Isn't this just a keyboard layout issue? Breton "ch" and "c'h" are not additional characters that need to be added to fonts; they're sequences of existing characters. If the Breton keyboard layout wants to provide them as single keystrokes, that's fine: those keystrokes should generate the corresponding sequences of two or three characters. But no font update is needed AFAICS.
I confirmed with the font design studio and yes like Jonathan mentioned this should be executed (fixed) within the keyboard.
Assignee: padamczyk → nobody
Rudy, can you look into this if or when you have sometime?
Flags: needinfo?(rlu)
If this is about the keyboard app, then we should dupe this issue to bug 1081567.
With that bug, we will have Breton keyboard layout implemented.
Status: NEW → RESOLVED
Closed: 7 years ago
Component: Gaia → Gaia::Keyboard
Flags: needinfo?(rlu)
Resolution: --- → DUPLICATE
Duplicate of bug: breton-keyboard
You need to log in before you can comment on or make changes to this bug.