All users were logged out of Bugzilla on October 13th, 2018

Firefox Nightly + Pinned tab + sessionstore = increasingly multiple windows on startup

RESOLVED DUPLICATE of bug 1081135

Status

()

RESOLVED DUPLICATE of bug 1081135
4 years ago
4 years ago

People

(Reporter: chadz85, Unassigned)

Tracking

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140925003805

Steps to reproduce:

Deleting sessionstore.js corrects the problem for a single firefox startup.
Removing all pinned tabs corrects the problem completely, but then you don't have your pinned tabs at start.
Reinstalled Firefox Nightly: issue remained.
Uninstalled Firefox Nightly and installed Firefox stable: issue no longer present.
I noticed the Issue begain Thursday October 8th, 2014.


Actual results:

Everytime there is a pinned tab, session store will cause multiple windows to open the next time Firefox Nightly is started (even after system restart). The number of windows will increase (seemingly exponentially) every time firefox is started should sessionstore.js not be deleted or pinned tab be present on closing.

There are no error messages presented when this issue occurs.


Expected results:

Firefox to open with a single window and pinned tab(s) as it used to normally do.
(Reporter)

Updated

4 years ago
Component: Untriaged → Session Restore

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081135
You need to log in before you can comment on or make changes to this bug.