"Remember this decision" does not work for choosing a client certificate on Firefox for Android

VERIFIED FIXED in Firefox 34

Status

()

VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: scriptjunkie, Assigned: mgoodwin)

Tracking

32 Branch
Firefox 36
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox33 wontfix, firefox34 verified, firefox35 verified, firefox36 verified, firefox37 verified, fennec+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

1. Visit site to issue certificate (https://scriptjunkie.us/getacert)
2. Tap the Generate button to get a certificate (and you are issued one)
3. Tap the link to https://www.scriptjunkie.us/auth/verifycert to use your certificate
"User Identification Request" prompt shows up, lists our certificate, has checkbox to "Remember this decision".
4. Leave checkbox selected to remember this decision and tap OK
5. Wait a few seconds.
6. Refresh the page or close tab and re-open or go back to the getacert page and tap the link to the verifycert page and you'll be prompted again to make the same decision.


Actual results:

You get prompted to choose a certificate every time you visit a site or URL that requests one.


Expected results:

Firefox should have remembered your choice, since you selected remember.
(Reporter)

Updated

5 years ago
Component: General → Search Activity
OS: Windows 8.1 → Android
Hardware: x86_64 → ARM
Component: Search Activity → General
tracking-fennec: --- → ?
(Assignee)

Updated

5 years ago
Assignee: nobody → mgoodwin
I actually took a look at it yesterday. The bug is on this line [1], | response.rememberBox | is true, but true != "true" in JS, so the comparison fails. Really simple to fix.

http://mxr.mozilla.org/mozilla-central/source/mobile/android/components/NSSDialogService.js?rev=313e5dcdfcb8#203
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

5 years ago
Posted patch bug1081711Splinter Review
changed "true" to true as per comment #1
Attachment #8509767 - Flags: review?(wjohnston)
Attachment #8509767 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/integration/fx-team/rev/04a67df19cd2
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
Once this bakes a bit, we should ask for approval on aurora and beta
tracking-fennec: ? → +
https://hg.mozilla.org/mozilla-central/rev/04a67df19cd2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36
[Tracking Requested - why for this release]: consider this for uplift into beta
status-firefox33: --- → affected
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
tracking-firefox34: --- → ?
tracking-firefox35: --- → ?
tracking-firefox36: --- → ?
Pretty simple one-line fix, not sure we need to track this since it's not clear this is a regression instead of a long term issue.  Please nominate for approval uplift so it can be considered on the basis of stability and risk.
Flags: needinfo?(mgoodwin)
status-firefox36: affected → fixed
tracking-firefox34: ? → ---
tracking-firefox35: ? → ---
tracking-firefox36: ? → ---
(Assignee)

Comment 9

5 years ago
Comment on attachment 8509767 [details] [diff] [review]
bug1081711

Approval Request Comment
[Feature/regressing bug #]: 1081711
[User impact if declined]: Users will have to re-select client certs for each visit to a site
[Describe test coverage new/current, TBPL]: No new or existing test coverage
[Risks and why]: Minimal; single line change to a line of code that never worked anyway.
[String/UUID change made/needed]: no.
Flags: needinfo?(mgoodwin)
Attachment #8509767 - Flags: approval-mozilla-beta?
Attachment #8509767 - Flags: approval-mozilla-aurora?
Attachment #8509767 - Flags: approval-mozilla-beta?
Attachment #8509767 - Flags: approval-mozilla-beta+
Attachment #8509767 - Flags: approval-mozilla-aurora?
Attachment #8509767 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/431266bc5e4d
https://hg.mozilla.org/releases/mozilla-beta/rev/f953384743a4
status-firefox33: affected → wontfix
status-firefox34: affected → fixed
status-firefox35: affected → fixed

Comment 11

4 years ago
Verified as fixed on all Firefox channels on Nexus 5(Android 5.0)
Status: RESOLVED → VERIFIED
status-firefox34: fixed → verified
status-firefox35: fixed → verified
status-firefox36: fixed → verified
status-firefox37: --- → verified

Comment 12

4 years ago
Trust SSL may be also correct.
Duplicate of this bug: 1061412
You need to log in before you can comment on or make changes to this bug.