extra blank line appears

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: attinasi)

Tracking

({testcase})

Trunk
mozilla1.1alpha
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
I'me attaching a testcase where a extra blank line appears.
Mozilla shows the testcase as:
----------------
test 1
test 2

test 3

test 1
test 2
test 3

while IE shows the testcase correctly as:
----------------
test 1
test 2
test 3

test 1
test 2
test 3

tested on build 20011101
(Reporter)

Comment 1

17 years ago
Created attachment 56239 [details]
testcase
Don't know what's going on here, will construct a valid testcase shortly. My
recent CVS build shows the extra line under test 1.
Keywords: testcase

Comment 3

17 years ago
Mozilla inserts a blank line.
Opera inserts a blank line.
IE inserts a blank line too, if you move the </p> tag up:

<p>
test 1<br></p><!-- close paragraph tag moved here --><div style="display:none">
- test 1a<br>
</div>

test 2<br><div style="display:none">
- test 2a<br>
</div>
test 3<br><div style="display:none">
- test 3a<br>
</div>
(Reporter)

Comment 4

17 years ago
I know it has something to do with the <p>
not sure what but it's weird....

Comment 5

17 years ago
Reduced testcase, with borders so you can see what's happening:

<p style="border: thin dashed">
test 1<div style="border: thin dashed"></div>
test 2<br>
test 3<br>

Comment 6

17 years ago
Created attachment 56420 [details]
Screenshot comparing IE/OP/NS rendering of reduced testcase
I think the cause of this line is that the <div> implicitly terminates the <p>.
Rendering of the testcase immediately above (with dotted borders) is the same if
I insert </p> just before the <div>; the thickish-looking dotted line is, of
course, the empty <div>. Are we actually doing anything wrong here?
Target Milestone: --- → mozilla1.1
Created attachment 63437 [details]
Testcase #2
I think the bug is in IE. In attachment 63437 [details] there are 3 examples. The first
is the reduced testcase of the problem: <P>text<DIV></DIV>
It could be parsed as (example 2) <P>text</P><DIV></DIV> 
or as (example 3) <P>text<DIV></DIV></P>
Mozilla and Opera does 2. IE seems to parse it as 2 but renders it with a quirk
of nuking the margin that normally is there when a proper end-tag is present.
I suggest resolving this as INVALID - I think we are doing the right thing.
Created attachment 88636 [details]
Testcase #3
I think we are doing the right thing here. (2002-06-20-08 trunk win98)
-> INVALID.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.