[Dialer] "cancel" is not translated for multiple languages

RESOLVED INVALID

Status

defect
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: KTucker, Assigned: gtorodelvalle)

Tracking

({regression})

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3][planned-sprint c=1])

Attachments

(3 attachments)

Description:
The word "Cancel" is not translated for multiple languages on the "Select audio sources" screen.

Repro Steps:
1) Update a Flame to 20141012001201
2) Change the language to French.
3) Pair a bluetooth headset to the phone. 
4) Open dialer and call another device.
5) Tap on the "Headset" button.
6) Observe the "Cancel" button. 

Actual:
The "Cancel" button is not translated. 

Expected:
The word "Cancel" is translated properly on all languages.

Environmental Variables:
Device: Flame 2.1
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 2/5 
See attached: logcat, Screenshot
This issue does not occur on Flame 2.1

The word "Cancel" is translated properly. 

Flame 2.1 

Device: Flame 2.1 KK (319mb) (Full Flash)
BuildID: 20141012001201
Gaia: d18e130216cd3960cd327179364d9f71e42debda
Gecko: 610ee0e6a776
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0a2 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
After talking with the reporter, the repro frequency is actually 100%.

Nominating this to block 2.2? because it is blocking the verification of bug 1073534
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Please disregard the build info in comment 0. Per bug 1073534 comment 8, the right 2.2 build info is:
Device: Flame 2.2 Master  KK (319mb) (Full Flash)
BuildID: 20141012040203
Gaia: 717ad4e8b7fc10ab8248500d00ba5ba0977fa8ab
Gecko: 44168a7af20d
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
Hardcoded issue, definitely needs to get fixed in 2.2
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][planned-sprint c=]
Target Milestone: --- → 2.1 S7 (24Oct)
Assignee: nobody → gtorodelvalle
Whiteboard: [2.1-exploratory-3][planned-sprint c=] → [2.1-exploratory-3][planned-sprint c=1]
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)
triage: regression, non-localized string
blocking-b2g: 2.2? → 2.2+
Hi guys! I just confirmed that, at least for me, it is working fine in Flame KK 2.2 (Gecko-2bfbd70.Gaia-6cbfaf9). In fact, having a look at the code it should work fine since the right l10n property name is used and the right locale file is linked.

Johan, regarding your comment 5 and just in case it was a temporal issue, would you be so kind to retry it with a recent build? Thank you very much!
Flags: needinfo?(jlorenzo)
Sorry, I won't have enough time to handle that today. QA wanted to check today's 2.2.
Flags: needinfo?(jlorenzo)
Keywords: qawanted
QA Contact: ckreinbring
The bug repros on German and Spanish on Flame 2.2 engineering (shallow flash) and nightly (full flash)
Actual result: When the user taps the headset button while in a call and connected to a Bluetooth headset, the Cancel button in the context menu that appears is shown in English instead of the chosen language.

Engineering
BuildID: 20141017073248
Gaia: 1daf2dadcd0d554c733661a4c0be1b82001e9da0
Gecko: 51892b39597a
Platform Version: 36.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Nightly
BuildID: 20141017040208
Gaia: abef62c0623e5504a97b4fd411e879a67b285b52
Gecko: ae1dfa192faf
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Platform Version: 36.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
Francesco, any idea what's going on here? In bug 1073534, we added a new string for master/v2.2, but used one of the properties inclusion hacks for v2.1. Thus my guess here is that we just don't have the string translated yet in other languages.
Flags: needinfo?(francesco.lodolo)
There's a simple explanation: We branched repositories to 2.1 this week, and gaia-l10n (the repository used to build master) is not yet updated for master. Therefor locales don't have that string yet.

The only locale you should be able to test at the moment is Italian.
Flags: needinfo?(francesco.lodolo)
Should we mark this as invalid then?
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #13)
> Should we mark this as invalid then?

Yes. It will be fixed in the coming weeks when all locales will update.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Target Milestone: 2.1 S8 (7Nov) → 2.1 S7 (24Oct)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
You need to log in before you can comment on or make changes to this bug.