If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Flame] Volume adjustment isn't linear and cuts off abruptly when sliding all the way to the minimum

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: gsvelto, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
This reproduces on a Flame with the v180 base image and a recent nightly build (20141009155936).

STR:

1. Play a vide on YouTube or play a game with continous music (I noticed this while playing Heroine Dusk which is available on the marketplace)
2. Use the volume buttons to adjust the volume all the way to the minimum until there's only one bar left
3. The sound should be barely audible, instead it's still pretty loud
4. Adjusting the volume further down mutes the phone as excepted and this happens abruptly since the sound is still fairly loud

Trying the same on my Keon the volume is correctly adjusted all the way down until it's almost whisper quiet at the minimum level and the transition to mute is hardly perceptible.

I'm filing this under Web Audio because since it's reproducible in multiple applications it's probably a platform problem but it might be a Gonk integration issue too. I'll verify if this reproduces on the old JB build too.
It sounds like you are getting a linear response, but of course you want a response close to exponential (with the slider corresponding to the logarithm of the gain).

Web Audio's gain node provides only a simple (linear) multiplier, and is not involved with YouTube video, so I very much doubt that this is web audio bug.

Are you implying that Flame and Keon have different behavior with the same Gecko version?

That difference in behavior suggests a device driver problem, unless Gecko is using different APIs on the different devices.

I'm moving to Video/Audio because I don't know where to file device driver bugs, but someone watching that component is more likely to know.
Component: Web Audio → Video/Audio
(Reporter)

Comment 2

3 years ago
(In reply to Karl Tomlinson (:karlt) from comment #1)
> It sounds like you are getting a linear response, but of course you want a
> response close to exponential (with the slider corresponding to the
> logarithm of the gain).

Actually I get a linear response on both devices WRT the slider however the Flame doesn't cut out at 0, it seems to be roughly half of the maximum volume when the slider is set at the minimum level.

> Web Audio's gain node provides only a simple (linear) multiplier, and is not
> involved with YouTube video, so I very much doubt that this is web audio bug.

Good point, when I saw the issue in a game I thought this might have been Web Audio related but after poking in the code I realized that it uses HTML5 Audio elements so it's definitely a lower level issue. Possibly caused by the JB -> KK transition on the Flame.

> Are you implying that Flame and Keon have different behavior with the same
> Gecko version?

Yes.
(Reporter)

Comment 3

3 years ago
Somehow this fixed itself recently. This must have been due to some issue in the older base images.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.