Unified_cpp_unicharutil_util0.obj 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in nsSuiteModule.obj

RESOLVED DUPLICATE of bug 1081519

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 1081519
3 years ago
3 years ago

People

(Reporter: Sladky Vladimir, Unassigned)

Tracking

SeaMonkey 2.32 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32a1
Build ID: 20140917135317

Steps to reproduce:

I compile with:

"C:\mozilla-build\mozmake\mozmake.exe" -f client.mk -s configure
export MAKE=mozmake
./mozilla/mach build


Actual results:

33:25.49 Executing: link -NOLOGO -DLL -OUT:suite.dll -PDB:suite.pdb -SUBSYSTEM:WINDOWS,5.02 -MACHINE:X64 @c:\Users\Vlada\comm-central\obj-x86_64-pc-mingw32\suite\build\tmp70b1k2.list module.res -LARGEADDRESSAWARE -NXCOMPAT -DYNAMICBASE -DEBUG -DEBUGTYPE:CV -DEBUG -OPT:REF -IMPLIB:fake.lib ../../xpcom/glue/xpcomglue_s.lib ../../memory/mozalloc/mozalloc.lib ../../config/external/nss/nss3.lib ../../toolkit/library/xul.lib ../../js/src/mozjs.lib -LIBPATH:../../dist/lib -NODEFAULTLIB:msvcrt -NODEFAULTLIB:msvcprt -DEFAULTLIB:mozcrt kernel32.lib user32.lib gdi32.lib winmm.lib wsock32.lib advapi32.lib secur32.lib netapi32.lib ole32.lib version.lib uuid.lib shell32.lib
33:25.49 c:\Users\Vlada\comm-central\obj-x86_64-pc-mingw32\suite\build\tmp70b1k2.list:
33:25.49     nsSuiteModule.obj
33:25.49     ..\feeds\src\nsFeedSniffer.obj
33:25.49     ..\profile\nsSuiteDirectoryProvider.obj
33:25.49     ..\profile\migration\src\nsNetscapeProfileMigratorBase.obj
33:25.49     ..\profile\migration\src\nsSuiteProfileMigratorUtils.obj
33:25.49     ..\profile\migration\src\nsThunderbirdProfileMigrator.obj
33:25.49     ..\shell\src\nsWindowsShellService.obj
33:25.49     ..\..\intl\unicharutil\util\Unified_cpp_unicharutil_util0.obj
33:25.49
33:25.49 Unified_cpp_unicharutil_util0.obj : error LNK2038: mismatch detected for 'RuntimeLibrary': value 'MT_StaticRelease' doesn't match value 'MD_DynamicRelease' in nsSuiteModule.obj
33:25.49
33:25.49    Creating library fake.lib and object fake.exp
33:25.49
33:25.50 suite.dll : fatal error LNK1319: 1 mismatches detected
33:25.50
33:25.50 c:/Users/Vlada/comm-central/config/rules.mk:859: recipe for target 'suite.dll' failed
33:25.50 mozmake[4]: *** [suite.dll] Error 1319
33:25.50 c:/Users/Vlada/comm-central/mozilla/config/recurse.mk:74: recipe for target 'suite/build/target' failed
33:25.50 mozmake[3]: *** [suite/build/target] Error 2
33:25.50 mozmake[3]: *** Waiting for unfinished jobs....
33:25.62    Creating library plugin-container.lib and object plugin-container.exp
33:25.62
33:25.62 MozillaRuntimeMain.obj : warning LNK4217: locally defined symbol ?ProvideLogFunction@warnonlysandbox@mozilla@@YAXP6AXPEBD00_NI@Z@Z (void __cdecl mozilla::warnonlysandbox::ProvideLogFunction(void (__cdecl*)(char const *,char const *,char const *,bool,unsigned int))) imported in function "void __cdecl mozilla::warnonlysandbox::PrepareForInit(void)" (?PrepareForInit@warnonlysandbox@mozilla@@YAXXZ)
33:25.62
33:25.65 Embedding manifest from c:/Users/Vlada/comm-central/mozilla/ipc/app/plugin-container.exe.manifest
33:25.77 c:/Users/Vlada/comm-central/mozilla/config/recurse.mk:36: recipe for target 'compile' failed
33:25.77 mozmake[2]: *** [compile] Error 2
33:25.77 c:/Users/Vlada/comm-central/mozilla/config/rules.mk:551: recipe for target 'default' failed
33:25.77 mozmake[1]: *** [default] Error 2
33:25.77 client.mk:404: recipe for target 'build' failed
33:25.77 mozmake.EXE: *** [build] Error 2
33:25.83 1206 compiler warnings present.
2

Vlada@PC1 ~/comm-central
$


Expected results:

Compile SM
(Reporter)

Updated

3 years ago
Hardware: x86 → x86_64

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081519
You need to log in before you can comment on or make changes to this bug.