Hash check for elasticutils and elasticsearch fails (for me)

RESOLVED FIXED in 2014Q4

Status

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: rrosario, Assigned: mythmon)

Tracking

unspecified
2014Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=dev c=infra p=1 s=2014.18)

(Reporter)

Description

4 years ago
I am getting the error below when creating a new virtualenv from scratch. Is it only me? Travis is fine so this is puzzling.

THE FOLLOWING PACKAGES DIDN'T MATCH THE HASHES SPECIFIED IN THE REQUIREMENTS
FILE. If you have updated the package versions, update the hashes. If not,
freak out, because someone has tampered with the packages.

    elasticutils: expected fADkAZ7n55EIe3ahrkBnNW642cQlHyk3zHcOkQrvMko
                       got CnOPMnGcdnU38yYRjBBcIZ5nfna3hUfthHxqqvvKDGU
    elasticsearch: expected u5PYXKflDWjkGXhSu226YJi7dyUA-C9dsv9KgHEVBck
                        got U6gisBsElN-WWMBOhyFhgOXsvoWxeGc92Eix-AnVwQA
-------------------------------
Not proceeding to installation.
(Reporter)

Comment 1

4 years ago
Actually, travis is seeing the same problem too:
https://travis-ci.org/mozilla/kitsune/builds/37817602

It looks like it's caused by this commit that was to fix the hashes:
https://github.com/mozilla/kitsune/commit/46b63ab4b1e42b1a9ec366b16d78119383428967
(Reporter)

Comment 2

4 years ago
Oh, is this related to Bug 1074861 ?
(Reporter)

Comment 3

4 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #2)
> Oh, is this related to Bug 1074861 ?

https://github.com/mozilla/kitsune/pull/2158 seems to fix it
You need to use the "--no-use-wheel" flag when running peep install.

This needs to be documented plus since it's a change in developer workflow that developers need to know about, we should have sent an email to the dev-sumo mailing list about what develoeprs need to do now and why.
(Reporter)

Comment 5

4 years ago
I still get the error when passing the flag.

$ pip --version
pip 1.5.2 from /Users/rlr/.virtualenvs/kitsune/lib/python2.7/site-packages (python 2.7)
$ ./scripts/peep.py install -r requirements/default.txt --no-use-wheel
#fails
Can you copy/paste the error?
(Reporter)

Comment 7

4 years ago
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #5)
> I still get the error when passing the flag.
> 
> $ pip --version
> pip 1.5.2 from /Users/rlr/.virtualenvs/kitsune/lib/python2.7/site-packages
> (python 2.7)
> $ ./scripts/peep.py install -r requirements/default.txt --no-use-wheel
> #fails

FALSE ALARM! Sorry! I was on a wrong older branch when I did this again. #HappyMonday
(Reporter)

Comment 8

4 years ago
Marking fixed with the PR mythmon landed.
Assignee: nobody → mcooper
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.