Infinite ringing if the caller closes the outgoing call window from the X button before the callee answers

RESOLVED DUPLICATE of bug 1081066

Status

Hello (Loop)
Client
RESOLVED DUPLICATE of bug 1081066
4 years ago
4 years ago

People

(Reporter: pauly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Closing the outgoing call window from the X button before the callee answers results in infinite calling on the callee side.
Note that 'Cancel' button instead of 'X' button works fine (bug 1074823)
I just fixed this in bug 1081066.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081066
(In reply to Paul Silaghi, QA [:pauly] from comment #2)
> FWIW, when the incoming call window is in the infinite ringing state on the
> callee side, pressing one of the Cancel/Accept buttons crashes Firefox:
> https://crash-stats.mozilla.com/report/index/dccec5ea-2e2b-462a-b1c3-
> e35852141013
> https://crash-stats.mozilla.com/report/index/aa893f9f-df94-4f5d-9d95-
> 10c982141013
> https://crash-stats.mozilla.com/report/index/f9715798-9135-4355-bd11-
> 064952141013

This looks like bug 1067348. We're in a content context here, so we shouldn't be crashing Firefox easily.
You need to log in before you can comment on or make changes to this bug.