[Compat Data] Drop browser.icon property

RESOLVED FIXED

Status

Mozilla Developer Network
General
--
enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jwhitlock, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:change])

(Reporter)

Description

3 years ago
What feature should be changed? Please provide the URL of the feature if possible.
==================================================================================
The browser resource should not have an icon property:  http://doesitwork-dev.allizom.org/api/v1/browsers/2


What problems would this solve?
===============================
The intent of the icon was to support displaying the browser logo in alternate displays of the compatibility data.  However, it is impossible to provide an image that is appropriate for all use cases.

Who would use this?
===================
browser.icon would be used by API client users in their user interface.

What would users see?
=====================
With browser.icon, API clients get an SSL URL to an image, and would have to view the image to determine size and format.  For the foreseeable future, browser.icon will be null, because we don't have appropriate images.

What would users do? What would happen as a result?
===================================================
With browser.icon, API client users would design their user interface around the provided images, if they have that flexibility.  Without it, API client users would procure or generate representative images in the desired size and format, and use the browser ID or slug as a lookup to the image URL.

Is there anything else we should know?
======================================
If / when we ship browser icons on MDN, we can document (outside of code) what images were used and the licenses of those images.  Mozilla could host on a CDN and provide embedded JS that uses them.
(Reporter)

Updated

3 years ago
Blocks: 996570
Severity: normal → enhancement
(Reporter)

Comment 1

3 years ago
Jeremie - I'd like to drop the icon property from browsers and move it into client software.  I'd like your feedback before I make the change.
Flags: needinfo?(jeremie.patonnier)
hi!

Yes, I agree that the icon shouldn't be part of the data model, let's get rid of it.

However, providing a canonical logo in various format and size could be a nice evolution for the service at some point. But not through the Data API itself. We could provide a specific API for that. Maybe something like the dummyimage service.

Maybe something like:

http(s)://browsercompat.com/logo/<width>x<height>/<browserId>.<imageFormat>
Flags: needinfo?(jeremie.patonnier)

Comment 3

3 years ago
Commit pushed to master at https://github.com/mozilla/web-platform-compat

https://github.com/mozilla/web-platform-compat/commit/69e04965e628a93090ca385e2b36731b295fb1d7
fix bug 1082044 - Drop browser.icon

Also drop the support code for validating icon URLs

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.