[Messages] bootstrap unit tests for startup.js

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sms-most-wanted])

(Reporter)

Description

4 years ago
startup.js is the only file without any unit test. This should change.

This bug should be about having at least _some_ unit tests. We'll likely need to extract the call to "init" in a separate file (init.js ?) so that we can call it repeatedly in the unit tests.
(Reporter)

Updated

4 years ago
Whiteboard: [sms-papercuts] → [sms-most-wanted]
Some tests were added in the scope of patch for bug 1109745. So I think we can close this one now :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
See Also: → bug 1109745
Duplicate of this bug: 1012670
You need to log in before you can comment on or make changes to this bug.