Please deploy Loop-Client 0.8.0 code to production

VERIFIED FIXED

Status

Cloud Services
Operations: Deployment Requests
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: standard8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
We'd like to deploy the loop-client 0.8.0 release to production.

https://github.com/mozilla/loop-client/releases/tag/0.8.0

We'd like to get it deployed to production tomorrow, Tuesday 13 Oct, as there's some information meant to be going out about the changes in this version.

No configuration changes required.
Whiteboard: [qa+]
Please get this pushed to Production *then* go back and switch to new Dev IAM.
We have teams and partners waiting for this.
Status: NEW → ASSIGNED
s/Dev IAM/Prod IAM/ or whatever it is called.
It seems that we are trying to push everything over to new IAMs right in the middle of big big releases that Prod, QA, clients, partners depend on for Fx34 and Fx35.

I realize there is no good time to do this, but perhaps consider rolling this out, then going back with QA/OPs help and redeploying to new stacks with new IAMs.

If that makes any sense at all...
I would feel MUCH better if this went out ASAP.  Mozilla is planning a blog post about Loop/Hello tomorrow at 9am Pacific.
Deployment complete.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Checking with ahughes to see if he wants to do any final checking, otherwise looks fine on our end.
Flags: needinfo?(anthony.s.hughes)
Just spoke with :ashughes and he gave thumbs up, so verifying.
Status: RESOLVED → VERIFIED
Flags: needinfo?(anthony.s.hughes)
ToS was missing on PROD so :deanw had to update new stage iam and re-deploy.  
ToS now present:
https://hello.firefox.com/legal/terms/

I've re-verified PROD by placing calls back and forth between Nightly and Aurora and everything looks good.
Needinfo'ing :ashughes so he's aware

FYI: Did find one minor (non-regression):
Bug 1084556 - Share Selected Devices pop-up window vanishes when re-sizing browser
Flags: needinfo?(anthony.s.hughes)
Richard, can you double check that ToS is loading properly from the client UI?
Flags: needinfo?(anthony.s.hughes)
Created attachment 8507289 [details]
invite_someone_to_talk_window.png
Created attachment 8507290 [details]
ready_to_start_your_conversation_window.png
Created attachment 8507293 [details]
ready_to_start_your_conversation_window_NIGHTLY.png
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #8)
> Richard, can you double check that ToS is loading properly from the client
> UI?

Hi Anthony, 

as I mentioned in Comment #7, thanks to :deanw, the link itself is now rendering properly on PROD
https://hello.firefox.com/legal/terms/
Let me know if you're not seeing that.

Since you asked, I did take another look and noticed that the user no longer has any path to the ToS on Aurora. 
https://bug1082176.bugzilla.mozilla.org/attachment.cgi?id=8507290
(I believe it used to be somewhere in the invite someone to talk window: https://bug1082176.bugzilla.mozilla.org/attachment.cgi?id=8507289)

The link to the ToS has, however, reappeared in Nightly (where it should be according to the design spec). 
https://bug1082176.bugzilla.mozilla.org/attachment.cgi?id=8507293
Flags: needinfo?(anthony.s.hughes)
Thanks Richard, I just had a look at Aurora.

In the Hello panel:
 * Terms of Service points to https://call.mozilla.com/legal/terms/
 * Privacy Policy points to https://www.mozilla.org/en-US/privacy/

In the Hello standalone page:
 * Terms of Service points to https://hello.firefox.com/legal/terms/
 * Privacy Policy points to https://www.mozilla.org/en-US/privacy/
Flags: needinfo?(anthony.s.hughes)
Thanks, Anthony.  Not sure why it wasn't rendering, but clearly it's back now.  As :jbonacci suggested, I think QA definitely sync-up to make sure we're covering all our bases.
You need to log in before you can comment on or make changes to this bug.