WebGL: Fix bogus assert validating mStencilBufferRefFront/Back

REOPENED
Assigned to

Status

()

Core
Canvas: WebGL
REOPENED
3 years ago
3 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

3 years ago
We're caching a value that is clamped internally, but not reading back the cached version as clamped.
(Assignee)

Comment 1

3 years ago
Created attachment 8504366 [details] [diff] [review]
bug1082225-bogus-clamp-assert.patch
Attachment #8504366 - Flags: review?(jgilbert)
This is actually a dupe of 1015561.
Let's just take the pre-r+'d patch there.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1015561
Comment on attachment 8504366 [details] [diff] [review]
bug1082225-bogus-clamp-assert.patch

Review of attachment 8504366 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/canvas/WebGLContext.h
@@ +1319,5 @@
>      GLfloat mColorClearValue[4];
>      GLint mStencilClearValue;
>      GLfloat mDepthClearValue;
>  
> +    GLint ClampStencilRef(GLint ref);

We don't want to expose this publically, since it's really just for our assertions, and surprisingly calls into GL instead of just recovering our expected values.
Attachment #8504366 - Flags: review?(jgilbert)
(Assignee)

Comment 4

3 years ago
Created attachment 8510088 [details] [diff] [review]
fix-clamp-assert.patch

Looks like it's an actual int to GL, so it needs clamping rather than masking.
Attachment #8504366 - Attachment is obsolete: true
Attachment #8510088 - Flags: review?(jgilbert)
(Assignee)

Updated

3 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

3 years ago
Created attachment 8510090 [details] [diff] [review]
fix-clamp-assert.patch

(w/ stray bits removed)
Attachment #8510088 - Attachment is obsolete: true
Attachment #8510088 - Flags: review?(jgilbert)
Attachment #8510090 - Flags: review?(jgilbert)
Attachment #8510090 - Flags: review?(jgilbert) → review+
You need to log in before you can comment on or make changes to this bug.