Closed Bug 1082226 Opened 8 years ago Closed 8 years ago

[SMS][MMS] MMS message displays broken image icon after sending.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1079546
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: Marty, Unassigned)

Details

(Keywords: regression, Whiteboard: [2.2-Daily-Testing])

Attachments

(3 files)

Attached image MMS_Screenshot.png
Description:
After sending an MMS with an image attached, the sending device will view that message with a broken image icon.  Attempting to open that attachment will only display a black image.

The file WILL be received properly by the MMS recipient.

Source images do not appear to be affected by this issue.

Sometimes, the image isn't broken immediately after sending, but will become broken after closing and restarting the Messaging app.

If the user forwards the MMS message to another Flame device, the image will appear broken in the same manner.  If the user forwards the message to a device on another Platform (iPhone and Windows Phone), the recipient will receive the following message:
'One or more of the message components have been deleted by MMS Adaptation. Either the message was too large or the components were unsuitable for your handset.'

This issue seems to happen to specific source images, but I have not seen any correlation between what images are and are not affected (screenshots, pictures taken by the phone, images imported via USB, images downloaded from the web).

Repro Steps:
1) Update a Flame device to BuildID: 20141013040202
2) Make sure there are several image files on your device (Screenshot, Photo, Image from web)
3) Open the messaging app.
4) Send each image in an MMS to another device.
5) Force close and re-open the messaging app, returning to the same thread.
  
Actual:
Images in sent MMS messages are corrupted.
  
Expected: 
Images in sent MMS messages do not become corrupted.
  
Environmental Variables:
Device: Flame 2.2 Master (319MB)
BuildID: 20141013040202 (Full Flash)
Gaia: 3b81896f04a02697e615fa5390086bd5ecfed84f
Gecko: f547cf19d104
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 35.0a1 (2.2 Master)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
  
Repro frequency: 3/6
See attached: screenshot, logcats

Attached is a logcat for both sending an MMS when it breaks, and attempting to open a broken MMS.

The attached screenshot not only visually demonstrates the issue, but is also on of the images that breaks when sending via MMS.
Attached file SendBrokenLog.txt
Attached file ViewBrokenLog.txt
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA, please test on v2.1 and v2.0.
It's clearly a regression, can we please find a window?

My guess is that it's a regression from bug 994190 but I feel we would have found the issue earlier in that case, so maybe another cause.
blocking-b2g: --- → 2.2?
This issue is NOT occurring on Flame 2.1.
Images sent in MMS messages remain properly viewable after the message is sent.

Environmental Variables:
Device: Flame 2.1 (319MB)
BuildID: 20141014001201 (Full Flash)
Gaia: 7e2e65a9668123b54c8cce5dacfdba6f4bd4672b
Gecko: 2325da834971
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Contact: jmercado
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
The revert of the fix for Bug 1059233 seems to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141008112805
Gaia: 11ef00785cf933165fa021d7a46b95a27c1600d6
Gecko: 8a43f1e47d82
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken 
Environmental Variables:
Device: Flame 2.2
BuildID: 20141008114303
Gaia: 9903497debc38227a158e4719871f1ac73691113
Gecko: beb9e2081386
Version: 35.0a1 (2.2) 
Firmware Version: v180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: 11ef00785cf933165fa021d7a46b95a27c1600d6
Gecko: beb9e2081386

First Broken gaia / Last Working gekko - Issue DOES occur
Gaia: 9903497debc38227a158e4719871f1ac73691113
Gecko: 8a43f1e47d82

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/11ef00785cf933165fa021d7a46b95a27c1600d6...9903497debc38227a158e4719871f1ac73691113
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Julien - take a look at the push-log if you will - it looks like this might have been caused by a revert
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(felash)
Keywords: qawanted
But the revert was a bad work around for another issue. Is it possible that you try builds from before bug 1059233?
Flags: needinfo?(felash) → needinfo?(jmitchell)
QA-Wanted: see comment 7
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: jmercado
I was unable to repro the bug on 9/10/2014 build of Flame 2.2 engineering with shallow flash.
Actual result: After sending a single or multiple ploto MMS, the photos show normally for the sender, even after closing and restarting the Messages app.

BuildID: 20140910011814
Gaia: 3f4c635106c5364228782d12b1cb76b0c105b971
Gecko: 3636378b38ee
Platform Version: 32.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
triage: regression
blocking-b2g: 2.2? → 2.2+
If the issue is fixed, can we have a reverse regression window? Thanks.
Chris, I think your hashes in comment 9 indicates v2.0, not v2.2. So it's perfectly normal that the bug is not happening with these variables.

I think it's been fixed by bug 1079546. Can you please try again, ensuring you really use a v2.2 build?
Flags: needinfo?(ckreinbring)
After double-checking the 2.2 version, I tried again on abother 9/10 build and was still unable to repro.
Actual result: After sending a single or multiple ploto MMS, the photos show normally for the sender, even after closing and restarting the Messages app.

BuildID: 20140910055413
Gaia: 8e02f689b0fc39cb6ccdc22d02ed7e219c58faa7
Gecko: 31ce2eb10676
Platform Version: 35.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ckreinbring) → needinfo?(jmitchell)
Keywords: qawanted
Thanks!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1079546
unblocking - resolved duplicate
blocking-b2g: 2.2+ → ---
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
You need to log in before you can comment on or make changes to this bug.