If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

M7 dumps core when changin colour preferences

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
P2
major
VERIFIED WORKSFORME
19 years ago
9 months ago

People

(Reporter: bugzilla, Assigned: Stuart Parmenter)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I'm using mozilla-i686-pc-linux-gnu-M7-fullcircle.tar.gz on an Intel Red Hat 6.0
box with a 2.2.10 kernel. It repeatably dumps core when selecting "colors" when
editing preferences:

Oh no!  ./apprunner just dumped a core file.

Do you want to debug this ? [y/n] y
/usr/bin/gdb ./apprunner core
GNU gdb 4.17.0.11 with Linux support
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...

warning: core file may not match specified executable file.
Core was generated by `/root/moz/package/./talkback/talkback -nub'.
Program terminated with signal 11, Segmentation fault.
#0  0x0 in ?? ()
(gdb) bt
#0  0x0 in ?? ()
#1  0x4015fcf2 in ?? ()
#2  0x401653d3 in ?? ()
#3  0x401e86f7 in ?? ()
#4  0x805925f in gtk_clist_column_titles_passive (clist=0x816d740)
    at gtkclist.c:1354
#5  0x805858a in gtk_clist_construct (clist=0x816d740, columns=2,
    titles=0xbffffb54) at gtkclist.c:1030
#6  0x8057998 in gtk_clist_class_init (klass=0x2) at gtkclist.c:604
#7  0x805530f in gtk_button_size_request (widget=0x0, requisition=0x2)
    at gtkbutton.c:436
#8  0x8057a9a in gtk_clist_class_init (klass=0x2) at gtkclist.c:647
(gdb)

This looks like it may be a gtk bug rather than a mozilla bug, but I figure
others are better positioned to make that judgement than me.

Tet

PS. Yes, I know M8's out now, but it's not on my local mirrors yet, and
mozilla.org is too slow from here...

Updated

18 years ago
Assignee: don → buster
Component: Browser-General → Editor
QA Contact: leger → janc

Comment 1

18 years ago
janc, are you abl to reproduce this with latest build?

Updated

18 years ago
Assignee: buster → trudelle
Component: Editor → Pref UI

Comment 2

18 years ago
Jan: unless I'm really misreading the description, this has nothing to do with
the editor.  I think the submitter is talking about changing color settings in
the prefs (Category=Appearance, Colors), not setting a color via the editor for
text in a document <font color=blue>, or whatever.)
Could the submitter please clear up this confusion for us?
Changing Component to Pref UI, assigning to peter t. for further assignment.

Updated

18 years ago
Assignee: trudelle → pavlov
Priority: P3 → P2
Target Milestone: M9

Comment 3

18 years ago
reassigning to pavlov as p2 for m9

Comment 4

18 years ago
Hello,

One question: How the heck are you getting FullCircle builds to work with Red
Hat 6.0??  For me, they *always* crash, and at the time (when M7 was current,
that is), I was told that it might be a while before the FullCircle folks got
Red Hat 6.0 support...  Has this changed since then?

I am thinking perhaps this is a FullCircle problem, and NOT a GTK+ problem...  I
notice that the first entries in the backtrace are unidentified, so this seems
likely to me...  Am I totally off-base here?  If I am not off-base, perhaps this
bug should be marked RESOLVED-INVALID, to get it off the radar?
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 5

18 years ago
this works fine for me.  try a later build.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
I can't recreate this either.  Marking verified.


Email response from <tethys@it.newsint.co.uk>:
"Correct, I was talking about the colour setting in preferences,
not in the editor."

Comment 7

18 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.