private browsing remembers pages, and may restore them after re-opening browser.

RESOLVED DUPLICATE of bug 1081135

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 1081135
4 years ago
4 years ago

People

(Reporter: thedicemaster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141013104125

Steps to reproduce:

1 i did some private browsing.
2 i closed the browser, and turned my computer off.
3 next time i started up my computer i opened firefox, which updated(nightly 36.0a1, 2014-10-13)


Actual results:

every single private window i had opened and closed in the last session was re-opened.
the last private window i had open was restored in a regular window, the "nightly was updated" page was loaded in a 2nd tab in the same window.


Expected results:

the private session should have been forgotten the moment i closed the windows.
a private session should never be restored into a regular session.

once i opened firefox after the update it should've only loaded the after-update page.
(Reporter)

Updated

4 years ago
Component: General → Private Browsing
If you open your preferences and visit the Privacy tab, what setting is selected for History?
Also, can you reproduce this behaviour regularly, or was it a once-off problem?

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081135
(Reporter)

Comment 4

4 years ago
thanks Loic. 
i missed that one because it's a slightly different issue with the same cause.
You need to log in before you can comment on or make changes to this bug.