[webide] if the manifest file has changed, don't reload the app, re-launch it

RESOLVED INVALID

Status

DevTools
WebIDE
RESOLVED INVALID
4 years ago
a month ago

People

(Reporter: paul, Unassigned)

Tracking

Trunk
x86_64
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
A reload is not enough to take into account changes in the manifest.

From bug 1032098:

(In reply to J. Ryan Stinnett [:jryans] from comment #3)
> (In reply to Alexandre Poirot [:ochameau] from comment #2)
> > There is two way to think about that, either WebIDE is smarter and knows
> > when we need to just reload the page or the whole app. In such case, it
> > would either call reload or stop/start.
> > 
> > But we can also tweak the actors.
> 
> As long as it's reasonable to do, I think detection like this should be in
> app actor.  The reason is that WebIDE doesn't really know the exact state of
> the app that is already installed, as the files could have been edited
> outside of WebIDE.  Since the app actor is on device, and the device can
> check easily what's already installed, it seems better to me to put such
> "smarts" in the actor.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1032098
Apps are being removed with B2G cleanup.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.