All users were logged out of Bugzilla on October 13th, 2018

Since Update i can't sync my google calendar or add a new google calendar

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: smunker, Unassigned)

Tracking

Lightning 3.3
x86_64
Windows 7

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.101 Safari/537.36

Steps to reproduce:

Since the Update to 'Provider for Google Calender' Version 1.0.1 the sync to my Google Calender doesn't work.
I tried to add a new appointment, the window didn't close.

When I try to add a new calendar i can login with my login data and I can accept the permissions. But I can't choose the calendar.
(Reporter)

Updated

4 years ago
OS: All → Windows 7
Hardware: All → x86_64
Currently many users are getting 'variableTermLimitExceeded' errors, i.e. Google doesn't allow more connections from Provider for Google Calendar for today.
(Reporter)

Comment 2

4 years ago
Created attachment 8504760 [details]
Google Calendar.PNG
(Reporter)

Comment 3

4 years ago
Created attachment 8504761 [details]
error console log.PNG

Comment 4

4 years ago
Add me to the list.  I get Google calendar temporarily unavailable icon next to my calendar, and am unable to add events.  When I click "Save and close", the window for the new event closes, but the item is not added to my calendar.  Also, if I try to add the calendar back using the "New calendar" dialog, when it gets to the box where I select which of my 3 Google calendars to add, there are no calendars listed.  I am running TB 31.2.0 with Lightning 3.3.1.  Since I cannot add a new calendar and cannot delete the current one, I'm stuck with a non-functioning Lightning.  I can access the calendar via Google, so it is not an issue with login credentials or Google.

Updated

4 years ago
Duplicate of this bug: 1083077

Comment 6

4 years ago
I've the same problem. A more detailed description and pictures can be found here: https://bugzilla.mozilla.org/show_bug.cgi?id=1083077

Comment 7

4 years ago
I found even older bug for this: Bug 1079659 - Google calendars suddenly no longer work

Comment 8

4 years ago
I'm getting the same trouble:
[calGoogleCalendar] Request GET https://www.googleapis.com/tasks/v1/users/@me/lists responded with HTTP 200

I'm using : provider_for_google_calendar-1.0.1-tb+sm.xpi with TB 31.2.0 on Win 7 Pro 64 bit

Before the upgrade I was using provider_for_google_calendar-0.32-tb+sm.xpi : it was working good but since many days it has stopped to work.

Comment 9

4 years ago
Created attachment 8505448 [details]
Error consolle for Google Calendar Provider 1.0.1 adding a new calendar

Error consolle for Google Calendar Provider 1.0.1 adding a new calendar

Comment 10

4 years ago
I am having the same problem (with a Google Apps for Education account, OSX 10.9.5, Thunderbird 31.2.0, Lightning 3.3.1, Provider for Google Calendar 1.0.1 if that makes a difference), and the message I get in the Error Console when I manually synchronize is:


[JavaScript Error: "[calCachedCalendar] replay action failed: null, uri=googleapi://<EMAIL_ADDRESS>/?calendar=<URL_ENCODED_EMAIL_ADDRESS>&tasks=%40default, result={
 "error": {
  "errors": [
   {
    "domain": "usageLimits",
    "reason": "variableTermLimitExceeded",
    "message": "Variable Term Limit Exceeded"
   }
  ],
  "code": 403,
  "message": "Variable Term Limit Exceeded"
 }
}
, op=[xpconnect wrapped calIOperation]"]

Comment 11

4 years ago
I've temporary fix it downgrading to provider_for_google_calendar-0.32-tb+sm.xpi.
It works now.

Comment 12

4 years ago
(In reply to fabio.fiadone from comment #11)
> I've temporary fix it downgrading to
> provider_for_google_calendar-0.32-tb+sm.xpi.
> It works now.

I can confirm that downgrading to 0.32 (and then removing & re-adding my calendar changing it back to using the private ical URL) works as a temporary fix. I also made sure to disable automatic updates for the add-on until there is a new version with a fix.
For recent support information please try <https://groups.google.com/forum/#!forum/provider-for-google-calendar>

The variableTermLimitExceeded issue can only be fixed at Googles side by increasing the quota/traffic/connections that is allowed for the Provider for Google extension.

Temporary workaround: Downgrade to old 0.32 release but this might only works until November 17, 2014 when Google shutdowns the old Google Calendar API v1. Or use Lightnings built-in CalDAV provider to access your Google calendars.

Comment 14

4 years ago
Same as Comments 4 and 12 in this thread.

Comment 15

4 years ago
Inviting you all to follow issue https://bugzilla.mozilla.org/show_bug.cgi?id=1079659

Comment 16

4 years ago
TRY CalDAV Solution: it works great in read and write access:

"An Explanation of the url format and how-to for CALDAV can be found here https://blog.mozilla.org/calendar/2013/09/google-is-changing-the-location-url-of-their-caldav-calendars/

CALDAV Url Format:https://apidata.googleusercontent.com/caldav/v2/your-email-address/events"

You could fine more details following:
https://bugzilla.mozilla.org/show_bug.cgi?id=1079659

Comment 17

4 years ago
Created attachment 8506656 [details]
New Calendar Wizard cannot subscribe Google Calendar

existing calendars work for me now, but subscribing doesn't.
Anton, your problem might be caused by the Thunderbirthday extension. I'd like to ask you to disable it and retest. Once you created your calendars you can re-enable it.
(Reporter)

Comment 19

4 years ago
(In reply to Stefan Sitter from comment #13)
> For recent support information please try
> <https://groups.google.com/forum/#!forum/provider-for-google-calendar>
> 
> The variableTermLimitExceeded issue can only be fixed at Googles side by
> increasing the quota/traffic/connections that is allowed for the Provider
> for Google extension.
> 
> Temporary workaround: Downgrade to old 0.32 release but this might only
> works until November 17, 2014 when Google shutdowns the old Google Calendar
> API v1. Or use Lightnings built-in CalDAV provider to access your Google
> calendars.

Today I read the google groups forum article and i installed the version 1.0.1 again. It works now, i can add appointments and i can add calendar in Lightning.
It seems, it was the GoogleAPI Quota.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 20

4 years ago
Stefan Sitter , 

> Anton, your problem might be caused by the Thunderbirthday extension

Yeah, exactly. It was that. I also seen message about it in Google Groups, but didn't catch up. Thanks!
You need to log in before you can comment on or make changes to this bug.