bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

The minimised status bar width must consider the software home button

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: gmarty, Assigned: gmarty)

Tracking

unspecified
2.1 S7 (24Oct)
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Assignee)

Description

4 years ago
After bug 1074028 landed, the minimised status bar width is now cached.
However, this width must be cached on several occasions like:
* The SHB is enabled/disabled
* Orientation changes (see Bug 1081407)

Also the width in landscape mode must take the SHB width into consideration.
(Assignee)

Updated

4 years ago
Blocks: 1074028
(Assignee)

Updated

4 years ago
Assignee: nobody → gmarty
[Blocking Requested - why for this release]:

Blocks a blocker.
blocking-b2g: --- → 2.1?
Flags: in-testsuite?
Whiteboard: [systemsfe]
Target Milestone: --- → 2.1 S7 (24Oct)
blocking-b2g: 2.1? → 2.1+
(Assignee)

Comment 3

4 years ago
Created attachment 8505417 [details]
Github PR

This patch addresses this issue and add a test.
It also fixes Bug 1081407. So I will close it when this one lands.
Attachment #8505417 - Flags: review?(etienne)
Attachment #8505417 - Flags: review?(21)
Comment on attachment 8505417 [details]
Github PR

r+ with nits.
Attachment #8505417 - Flags: review?(21) → review+
Comment on attachment 8505417 [details]
Github PR

Comments on github, I'd like to discuss them before landing this.
Attachment #8505417 - Flags: review?(etienne)
(Assignee)

Comment 6

4 years ago
Comment on attachment 8505417 [details]
Github PR

Etienne, I implemented all the changes we discussed offline. Can you please review it? There are significant changes since last time you reviewed it.
Attachment #8505417 - Flags: review+ → review?(etienne)
Comment on attachment 8505417 [details]
Github PR

r=me (tiny nit on github) with a follow up bug filed to "Expand statusbar_icon_visibility_test.js to cover basic icon prioritization use cases", we really need it :)
Attachment #8505417 - Flags: review?(etienne) → review+
(Assignee)

Comment 8

4 years ago
Landed in master:
https://github.com/mozilla-b2g/gaia/commit/4925cc675c715ef644663164e80ad15e7865fc4f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

4 years ago
Comment on attachment 8505417 [details]
Github PR

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1074028 and the status bar icons prioritisation
[User impact] if declined: The minimised status bar width is not updated and icons overlap on the rocket bar
[Testing completed]: Manual testing is required
[Risk to taking this patch] (and alternatives if risky): Low risk
[String changes made]: None
Attachment #8505417 - Flags: approval-gaia-v2.1?(bbajaj)
(Assignee)

Comment 10

4 years ago
Thanks Etienne for the r+. This bug has a in-testsuite flag on, so it's on our radar for bug needed integration tests.
Blocks: 1084081
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1081407
Attachment #8505417 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+
Guillaume, we need a branch specific patch here for 2.1. Can you help us out?
Flags: needinfo?(gmarty)
(Assignee)

Comment 13

4 years ago
Created attachment 8508612 [details] [review]
Github PR v2.1

Here's a PR for v2.1. I'm not sure what's the usual way to do here. Should this patch be r+ before landing? It's essentially the same as on master with the unit test adapted.
Flags: needinfo?(gmarty)
Attachment #8508612 - Flags: feedback?(mhenretty)
We usually don't bother with re-review on trivial rebases as long as the Gaia Try run is green. That said, Github says this needs rebasing before it can be merged.
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(gmarty)
(Assignee)

Comment 15

4 years ago
Thanks Ryan for letting me know. It's rebased now. Let's wait on Gaia-try to reopen now.
Flags: needinfo?(gmarty)
(Assignee)

Updated

4 years ago
Attachment #8508612 - Flags: feedback?(mhenretty)
Depends on landscape b2g desktop.
Depends on: 1080309
Flags: in-testsuite? → in-testsuite-
Created attachment 8622907 [details]
minimised status bar.png

This issue is verified "pass" on latest flame v2.1&v2.2 build.
STR:
Precondition:Two active SIM cards are inserted to device and the wi-fi is connected.
1.Launch Settings and Enable SHB in "Developer".
2.Make enough icons are displayed on status bar, such as: bluetooth, NFC, Geolocation etc
3.Launch Browser and browse youtube website.
4.Switch the device to landscape mode.
5.Observe the minimized status bar and maximized status bar.

Actual result:The icons of two sim cards are displayed in the minimized status bar normally.

See attachment: minimised status bar.png.
Reproducing rate:0/10

Device: Flame 2.1 build (Pass)
Build ID               20150615001205
Gaia Revision          f8b848c82d1ed589f7a1eb5cc099830c867ff1d4
Gaia Date              2015-06-08 09:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/7d767fc15126
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150615.040550
Firmware Date          Mon Jun 15 04:06:02 EDT 2015
Bootloader             L1TC000118D0
 
Device: Flame 2.2 build (Pass)
Build ID               20150615162504
Gaia Revision          e7a0c6d5f4df04d45fb3f726efb9e8223600cb79
Gaia Date              2015-06-15 06:12:18
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8045028bf400
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150615.194936
Firmware Date          Mon Jun 15 19:49:47 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.