go_to_url(self, url) doesn't escape ~ to browse http://people.mozilla.com/~login/

RESOLVED FIXED

Status

Firefox OS
Gaia::UI Tests
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: nbp, Assigned: jlorenzo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 8504927 [details]
Marionette report & logcat.

This issues started on/after October 8th, and AWFY FxOS devices are no longer working since.

Marionette test used:
  https://github.com/nbp/gaia-ui-tests/blob/bench/gaiatest/tests/browser/benchmarks/test_bench_sunspider.py

(The gaia-ui-test repository is out-dated, but I have not yet updated the location of the benchmarks)

The problem is within/after " browser = search.go_to_url(self._start_page) " as Visit url is spewed and the address is being composed in the search bar.
Can anybody investigate this issue?  This is blocking the benchmarking of scores to AWFY:
http://arewefastyet.com/#machine=26

FYI, The browser application remains with the page loaded, even after Marionette crash.
Flags: needinfo?(jgriffin)
Malini, do you have time to look at this?
Flags: needinfo?(jgriffin) → needinfo?(mdas)
Since this started about Oct 8, could this be the culprit?

http://hg.mozilla.org/mozilla-central/rev/71e05880cbb0
(In reply to Jonathan Griffin (:jgriffin) from comment #3)
> Since this started about Oct 8, could this be the culprit?
> 
> http://hg.mozilla.org/mozilla-central/rev/71e05880cbb0

I reverted this patch locally for the flame and I will see if this is working in ~40mins.
(In reply to Nicolas B. Pierron [:nbp] from comment #4)
> I reverted this patch locally for the flame and I will see if this is
> working in ~40mins.

Oct 15 20:19:08 hydra run-chroot.sh[21779]: Results will not be posted to Treeherder. Please set the following environment variables to enable Treeherder reports: TREEHERDER_KEY, TREEHERDER_SECRET
Oct 15 20:19:08 hydra run-chroot.sh[21779]: starting httpd
Oct 15 20:19:08 hydra run-chroot.sh[21779]: running webserver on http://192.168.0.105:59478/
Oct 15 20:19:08 hydra run-chroot.sh[21779]: SUITE-START | Running 1 tests
Oct 15 20:19:08 hydra run-chroot.sh[21779]: TEST-START | test_bench_sunspider.py TestBenchSunspider.test_sunspider
Oct 15 20:19:08 hydra run-chroot.sh[21779]: Visit url http://people.mozilla.com/~npierron/sunspider/hosted/
Oct 15 20:19:08 hydra run-chroot.sh[21779]: TEST-UNEXPECTED-ERROR | test_bench_sunspider.py TestBenchSunspider.test_sunspider | TimeoutException: TimeoutException: Timed out after 10.2 seconds
Oct 15 20:19:08 hydra run-chroot.sh[21779]: Traceback (most recent call last):
Oct 15 20:19:08 hydra run-chroot.sh[21779]: File "/home/awsa/flame/inbound/gecko/testing/marionette/client/marionette/marionette_test.py", line 267, in run
Oct 15 20:19:08 hydra run-chroot.sh[21779]: testMethod()
Oct 15 20:19:08 hydra run-chroot.sh[21779]: File "/home/awsa/flame/inbound/perso/gaia-ui-tests/gaiatest/tests/browser/benchmarks/test_bench_sunspider.py", line 30, in test_sunspider
Oct 15 20:19:08 hydra run-chroot.sh[21779]: browser = search.go_to_url(self._start_page)
Oct 15 20:19:08 hydra run-chroot.sh[21779]: File "/home/awsa/flame/inbound/gaia/tests/python/gaia-ui-tests/gaiatest/apps/search/app.py", line 27, in go_to_url
Oct 15 20:19:08 hydra run-chroot.sh[21779]: return search_panel.go_to_url(url)
Oct 15 20:19:08 hydra run-chroot.sh[21779]: File "/home/awsa/flame/inbound/gaia/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/search_panel.py", line 39, in go_to_url
Oct 15 20:19:08 hydra run-chroot.sh[21779]: self.wait_for_condition(lambda m: urllib.quote(url, safe=':/?=') in self.apps.displayed_app.name)
Oct 15 20:19:08 hydra run-chroot.sh[21779]: File "/home/awsa/flame/inbound/gaia/tests/python/gaia-ui-tests/gaiatest/apps/base.py", line 56, in wait_for_condition
Oct 15 20:19:08 hydra run-chroot.sh[21779]: Wait(self.marionette, timeout).until(method, message=message)
Oct 15 20:19:08 hydra run-chroot.sh[21779]: File "/home/awsa/flame/inbound/gecko/testing/marionette/client/marionette/wait.py", line 143, in until
Oct 15 20:19:08 hydra run-chroot.sh[21779]: cause=last_exc)
Oct 15 20:19:08 hydra run-chroot.sh[21779]: TEST-INFO took 105042ms
Oct 15 20:19:08 hydra run-chroot.sh[21779]: SUMMARY
Oct 15 20:19:08 hydra run-chroot.sh[21779]: -------
Oct 15 20:19:08 hydra run-chroot.sh[21779]: passed: 0
Oct 15 20:19:08 hydra run-chroot.sh[21779]: failed: 1
Oct 15 20:19:08 hydra run-chroot.sh[21779]: todo: 0
Oct 15 20:19:08 hydra run-chroot.sh[21779]: FAILED TESTS


This does not seems to improve, and apparently I quoted the wrong part of the log previously, as the timeout was related to the setup and not go_to_url, as this one is.
Not today, will try for early next week
(Assignee)

Comment 7

4 years ago
This change, merged on October 8th, is the cause: https://github.com/mozilla-b2g/gaia/pull/24708/files#diff-b8faa448e334a8d976777976057a90d6R39

You use a ~ in your URL, which is now escaped but wasn't before. I'll provide a patch shortly.
Blocks: 1068016
Component: Marionette → Gaia::UI Tests
Flags: needinfo?(mdas)
Product: Testing → Firefox OS
Version: 35 Branch → unspecified
(Assignee)

Updated

4 years ago
Summary: switchToFrame fails with (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "chrome://specialpowers/content/SpecialPowersObserver.js" line: 102} → go_to_url(self, url) doesn't escape ~ to browse http://people.mozilla.com/~login/

Comment 8

4 years ago
No-Jun made the change that broke this so I'll CC him on it, he may have a contribution.
(Assignee)

Comment 9

4 years ago
Created attachment 8507728 [details] [review]
Gaia PR

I added ~ as a safe character. I also added &.
Attachment #8507728 - Flags: review?(npark)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #7)
> This change, merged on October 8th, is the cause:
> https://github.com/mozilla-b2g/gaia/pull/24708/files#diff-
> b8faa448e334a8d976777976057a90d6R39
> 
> You use a ~ in your URL, which is now escaped but wasn't before. I'll
> provide a patch shortly.

For the moment I reverted the patch locally and this indeed fix the issue on AWFY.
Thanks for investigating :)
Comment on attachment 8507728 [details] [review]
Gaia PR

Thanks for finding this out.  this looks good to me.  I'm surprised that I missed the failed test when I ran the gaiatest suite after the patch.
Attachment #8507728 - Flags: review?(npark) → review+
Created attachment 8512322 [details] [diff] [review]
Introduce PPrinting.ipdl and proxies for opening printing UI. r=?
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Comment on attachment 8512322 [details] [diff] [review]
Introduce PPrinting.ipdl and proxies for opening printing UI. r=?

Whoops - fat-fingered.
Attachment #8512322 - Attachment is obsolete: true
QA Whiteboard: [fxosqa-auto-backlog+]
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-backlog-]
(Assignee)

Comment 14

4 years ago
Comment on attachment 8507728 [details] [review]
Gaia PR

Do you think it's ready to merge?
Attachment #8507728 - Flags: review?(florin.strugariu)
Attachment #8507728 - Flags: review?(florin.strugariu) → review-
(Assignee)

Comment 15

4 years ago
Comment on attachment 8507728 [details] [review]
Gaia PR

Oh look, a cute cat! Now it's gone :)
Attachment #8507728 - Flags: review- → review?(florin.strugariu)
Comment on attachment 8507728 [details] [review]
Gaia PR

Looks OK now

Thanks for the fix Johan
Attachment #8507728 - Flags: review?(florin.strugariu) → review+
https://github.com/mozilla-b2g/gaia/commit/f8ed36b1a4dd7bda2f7244246bd9d5b9bf22811b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.