If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

OOM crash with a page from mjpg-streamer

RESOLVED DUPLICATE of bug 882990

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 882990
3 years ago
2 years ago

People

(Reporter: illumilor.e, Unassigned)

Tracking

32 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 2014092000

Steps to reproduce:

Went to a website that streams mjpg pictures


Actual results:

Firefox had a memory leak that filled up 16gb of ram in a minute then locked up


Expected results:

Should not crash.
Hello,

can you please give us a specific page?
this would help us to reproduce the problem in detail.
Flags: needinfo?(illumilor.e)
(Reporter)

Comment 2

3 years ago
Any page that streams mjpg pictures. 
Viewing any page created by
http://sourceforge.net/projects/mjpg-streamer/
will recreate the crash.
Flags: needinfo?(illumilor.e)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)

Comment 6

3 years ago
so is there a public testcase somewhere (link)? Or is anybody trying to reproduce expected to use that application you linked to to create a testcase first? Steps to reproduce are still unclear...
Flags: needinfo?(illumilor.e)
(Reporter)

Comment 7

3 years ago
It happens on any streaming jpg site, so step one is to set up a page that has that, either from installing the mjpg streamer app or anything else that creates it. The site that I noticed this on  Step 2 is to then go to that page and wait for maybe ten minutes depending on the size of the page. Step 3 is to notice that once your ram has been used up by firefox, that your hard drive is now thrashing and your machine is locking up. Then either firefox crashes or the machine completely freezes. Again, this happens in kubuntu and win7 when using firefox. I tested it in chromium, but that doesn't even display the stream at all.
Flags: needinfo?(illumilor.e)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)

Comment 12

3 years ago
> Went to a website that streams mjpg pictures

are not really helpful steps to reproduce, because I have no idea how to find such a website.
Please provide a public testcase.
Flags: needinfo?(illumilor.e)
Comment hidden (obsolete)
Comment hidden (obsolete)

Comment 15

3 years ago
Don't have time to create testcases - if you want a bug to get fixed, please make it as easy as possible for developers by providing a testcase or even a patch to fix it. Otherwise the bug likely will not get fixed.
Flags: needinfo?(illumilor.e)
(Reporter)

Comment 16

3 years ago
My isp doesn't allow me to set up servers, so I can't provide a direct link. If you are on ubuntu installing the deb, running the command, and pointing firefox at it would take less than a couple of minutes. If any of you have any idea of how to make an easier testcase, tell me.
Flags: needinfo?(illumilor.e)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Keywords: testcase-wanted
Resolution: --- → DUPLICATE
Summary: Firefox crashes → OOM crash with a page from mjpg-streamer
Duplicate of bug: 882990
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.