All users were logged out of Bugzilla on October 13th, 2018

TypeError: context is null at: app://callscreen.gaiamobile.org/gaia_build_defer_index.js line: 84

RESOLVED DUPLICATE of bug 1079810

Status

RESOLVED DUPLICATE of bug 1079810
4 years ago
4 years ago

People

(Reporter: anshulj, Assigned: gsvelto)

Tracking

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [caf priority: p2][CR 741215][planned-sprint c=3])

(Reporter)

Description

4 years ago
[Blocking Requested - why for this release]: This exception is preventing us to run our unit test to ensure the quality of this release.

I am seeing the following exception while running marionette test cases related to SIM card locks, which is causing the test to fail. 

JavascriptException: TypeError: context is null at: app://callscreen.gaiamobile.org/gaia_build_defer_index.js line: 84
Component: Gaia::System → Gaia::Dialer
Please provide a STR.
Flags: needinfo?(anshulj)
(Reporter)

Comment 2

4 years ago
I don't have STR as the issue doesn't happen persistently.
Flags: needinfo?(anshulj)
triage: I'm afraid we can't + it without being able to reproduce it.
Could you provide some more information?
blocking-b2g: 2.1? → -
Flags: needinfo?(anshulj)
Assignee: nobody → gsvelto
Target Milestone: --- → 2.1 S7 (24Oct)
(Reporter)

Comment 4

4 years ago
Doug, the error is not easily reproducible and after spending quite some time I couldn't produce STR. I am still seeing the error 1/20 times I run my test script. Could you point me to the file that might be throwing this error, I can add some debug message on console.trace() to possibly help debug?
Flags: needinfo?(anshulj)
waiting for anshul to see if he has more logs to investigate this further per comment #4,5.

Updated

4 years ago
Flags: needinfo?(anshulj)

Updated

4 years ago
Whiteboard: [CR 741215]

Updated

4 years ago
Whiteboard: [CR 741215] → [caf priority: p2][CR 741215]
(Assignee)

Comment 7

4 years ago
I think this might be caused by a race condition whereas we trash the audio context and then try to play. See bug 834530 comment 50 of why this might be happening. The changes I'm doing in that bug should prevent those races so it might be worth re-testing this after that bug lands.
See Also: → bug 834530
Whiteboard: [caf priority: p2][CR 741215] → [caf priority: p2][CR 741215][planned-sprint c=]
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)
Whiteboard: [caf priority: p2][CR 741215][planned-sprint c=] → [caf priority: p2][CR 741215][planned-sprint c=3]
Anshul, could you try the patches in bug 834530 and see if they fix the issue here?

That would be attachment 8508778 [details] [diff] [review] and attachment 8511646 [details] [diff] [review].
Flags: needinfo?(anshulj)
Toggling needinfo off and on again for visibility.
Flags: needinfo?(anshulj)
(Reporter)

Comment 10

4 years ago
Doug I am not able to reproduce this error anymore even without the patch. I am marking this issue closed for now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(anshulj)
Resolution: --- → WORKSFORME
Thanks for checking. I could definitely be wrong here, but I strongly suspect that bug 1079810 fixed this.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1079810

Updated

4 years ago
No longer blocks: 1074290
You need to log in before you can comment on or make changes to this bug.