Closed Bug 1082885 Opened 8 years ago Closed 8 years ago

[SHB] Input method prompt is overlapped by SHB

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 verified)

VERIFIED FIXED
2.1 S7 (24Oct)
blocking-b2g 2.1+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified

People

(Reporter: mikehenrty, Assigned: mikehenrty)

References

Details

(Whiteboard: [systemsfe])

Attachments

(3 files)

STR:

1.) Go to Settings->Keyboards and add a new keyboard (like Spanish)
2.) Go to Messages app, and bring up the keyboard
3.) Long press on the select language key (lower left)

Actual result:
SHB overlaps the keyboard select prompt.

Expected result:
SHB does not overlap the prompt.
[Blocking Requested - why for this release]:

It's unclear to me whether this dialog ever worked with the software home button, but even if it is not a regression it still looks pretty bad.
blocking-b2g: --- → 2.0?
[Blocking Requested - why for this release]:
blocking-b2g: 2.0? → 2.1?
Attachment #8505079 - Flags: review?(etienne)
Broken feature.
blocking-b2g: 2.1? → 2.1+
Assignee: nobody → mhenretty
Target Milestone: --- → 2.1 S7 (24Oct)
Comment on attachment 8505079 [details] [review]
[Gaia PR] make ime shb aware

r=me with the comments on the test addressed
Attachment #8505079 - Flags: review?(etienne) → review+
Adding qawanted for branch/regression check.
Keywords: qawanted
QA Contact: aalldredge
This issue reproduces in 2.1 Flame and 2.2 Flame.

Environmental Variables:
Device: Flame 2.2 Master (Shallow Flash)
BuildID: 20141014171832
Gaia: 5f1f0960ae9d22acf2a324ad37a48174d6df87f6
Gecko: 62f0b771583c
Version: 36.0a1 (2.2)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 (Shallow Flash)
BuildID: 20141015040132
Gaia: 82565292c0fa86e3ddcda290cae7f5cb702f654c
Gecko: d8d578cb569c
Version: 34.0 (2.1)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
The SHB is overlapping the the input method  prompt.
--------------------------------------------------------------------
This issue does not occur on 2.0 Flame.

Device: Flame 2.0 (Shallow Flash)
BuildID: 20141014194629
Gaia: c6c6116ca225c2c934220ae6867e5a3256d65e00
Gecko: 24a2aa6bf1c4
Gonk: 
Version: 32.0 (2.0)
Firmware: V180
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Result:
The input method prompt overlaps the SHB.(screenshot attached)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawantedregression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(In reply to Adam Alldredge [:AdamA] from comment #9)
> Created attachment 8505681 [details]
> 2.0 SHB being overlapped.

Did you enable the SHB here? Thats the reverse to what we are seeing.
Flags: needinfo?(aalldredge)
(In reply to KTucker [:KTucker] from comment #7)
> Adding qawanted for branch/regression check.

I don't think we need 2.0 checks for SHB bugs in the future. The feature existed before but 2.1 is the first official release that supports the SHB. We know that the feature had many bugs before that. This should save you some time :)
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
Keywords: regression
Yes, I enabled the software home button in that image.
Flags: needinfo?(aalldredge)
FTR, software home button was probably pretty broken in 2.0.
master: https://github.com/mozilla-b2g/gaia/commit/4a9252f6ff519ba0b6f6c137b30d2f769ab1fb58
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8505079 [details] [review]
[Gaia PR] make ime shb aware

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Not a regression, this screen never worked with SHB.

[User impact] if declined:
Poor UX when trying to switch input methods.

[Testing completed]:
Tested on device, and new integration test.

[Risk to taking this patch] (and alternatives if risky):
css only change, specific to IME dialog, tested with integration tests.

[String changes made]: none.
Attachment #8505079 - Flags: approval-gaia-v2.1?
Flags: in-testsuite+
Attachment #8505079 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Issue verified fixed in Flame 2.1 and Flame 2.2

Actual Results: No part of the input method prompt screen is covered by the Software Home Button. Both the cancel button and the home button function correctly.

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141022001201
Gaia: 3d9cc667f4e929861a9a77c41096bbf5a9c1bde0
Gecko: 928b18f7d8ff
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141022040201
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: ae4d9b4ff2ee
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Version: 36.0a1 (2.2)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.