The default bug view has changed. See this FAQ.

New mail notification shows garbled sender name when name is encoded.

RESOLVED FIXED in Thunderbird 37.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: Jorg K (GMT+1), Assigned: jcranmer)

Tracking

({regression})

33 Branch
Thunderbird 37.0
x86_64
Windows 7
regression

Thunderbird Tracking Flags

(thunderbird36?)

Details

(Whiteboard: [regression:TB??])

Attachments

(6 attachments)

(Reporter)

Description

3 years ago
Created attachment 8505072 [details]
notification.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

Receive a message from a sender that uses encoding in the "From:" header, for example:
From: =?UTF-8?Q?J=c3=b6rg_Knobloch?= <mozilla@jorgk.com>


Actual results:

The "international" character isn't shown correctly (see enclosed).
Also, the folder notification when hovering over a folder that contains the new message shows the same garbled character. See screenshots enclosed.


Expected results:

"International" character should be shown correctly as in version 24.x. I'm using 33 (beta) since 31.x has too many bugs.
(Reporter)

Comment 1

3 years ago
Created attachment 8505074 [details]
Bad text in folder popup notification

Updated

3 years ago
Keywords: regression
(Reporter)

Updated

3 years ago
Summary: New mail notification shows garbled sender name when name is encoded → New mail notification shows garbled sender name when name is encoded. Text body also rendered badly.
(Reporter)

Comment 2

3 years ago
Created attachment 8505371 [details]
notification2.png

This shows the original bug, bad character in sender's name, in this case
From: "=?windows-1252?Q?Departamento_de_Administraci=F3n?=" <info@grupoioe-formacion.es>

plus two more bugs:
Some bits of the message body are displayed verbatim, that is M&aacute;ster instead of Máster.

The new message count of 254 is also wrong.
(Reporter)

Comment 3

3 years ago
Created attachment 8505508 [details]
folder pop-up.png

Another example of a bad character showing in the folder pop-up.
(Reporter)

Comment 4

3 years ago
I tried version 31.2.0, the current "official" version at time of writing.
Version 31.2.0 does NOT show this problem.
(Reporter)

Updated

2 years ago
Summary: New mail notification shows garbled sender name when name is encoded. Text body also rendered badly. → New mail notification shows garbled sender name when name is encoded. HTML body preview also rendered badly.
(Assignee)

Comment 5

2 years ago
Created attachment 8511589 [details] [diff] [review]
Fix the popup

This is a relatively easy fix. The hard part is adding a test for this in automated tests--the notification tests go through the alert service, which bypasses the newmail.xul dialog.
Assignee: nobody → Pidgeot18
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8511589 - Flags: review?(mkmelin+mozilla)
(Reporter)

Comment 6

2 years ago
Please excuse my asking: Does this also fix the badly rendered HTML in the body preview?
Refer to attachment notification2.png and comment #2. Displayed is "M&aacute;ster" instead of "Máster" and "Gesti&oacute;n" instead of "Gestión".
Is this a regression of jsmime checkin?
Keywords: regressionwindow-wanted
Whiteboard: [regression:TB??]

Comment 8

2 years ago
Comment on attachment 8511589 [details] [diff] [review]
Fix the popup

Review of attachment 8511589 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #8511589 - Flags: review?(mkmelin+mozilla) → review+
(Reporter)

Comment 9

2 years ago
Please excuse my asking: Does this also fix the badly rendered HTML in the body preview?
Refer to attachment notification2.png and comment #2. Displayed is "M&aacute;ster" instead of "Máster" and "Gesti&oacute;n" instead of "Gestión".

Can someone please answer "Yes" or "No.

Comment 10

2 years ago
No, this fix only affects the sender name. So
(Reporter)

Comment 11

2 years ago
"So"?

So what about the body? That looks just as bad (see notification2.png).

Comment 12

2 years ago
(that "So" wasn't meant there.)
We probably need a sample mail to see what the body issue could be about.
(Reporter)

Comment 13

2 years ago
Created attachment 8515309 [details]
Two notifications with garbled HTML and the corresponding messages

Here you go.
These are the original messages as they were received together with the screenshots taken when they arrived.
tracking-thunderbird37: --- → ?
(Assignee)

Comment 14

2 years ago
https://hg.mozilla.org/comm-central/rev/26b1b0b09ee3

(In reply to Jorg K from comment #11)
> So what about the body? That looks just as bad (see notification2.png).

This is best handled in a separate bug; it's really two distinct issues.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 37.0
(Reporter)

Updated

2 years ago
Attachment #8515309 - Attachment description: Two notifications with garbles HTML and the corresponding messages → Two notifications with garbled HTML and the corresponding messages
(Reporter)

Comment 15

2 years ago
HTML issue moved to bug 1108218.
Summary: New mail notification shows garbled sender name when name is encoded. HTML body preview also rendered badly. → New mail notification shows garbled sender name when name is encoded.
(In reply to Wayne Mery (:wsmwk) from comment #7)
> Is this a regression of jsmime checkin?

was it decided this is not a regression?
if it is, what is to blame?
Flags: needinfo?(mozilla)
Flags: needinfo?(Pidgeot18)
(Reporter)

Comment 17

2 years ago
I feel honoured by the question, but I wouldn't have a clue.
I had to google "jsmime" and found this bug 959309.
Flags: needinfo?(mozilla)
(Assignee)

Comment 18

2 years ago
(In reply to Wayne Mery (:wsmwk) from comment #16)
> (In reply to Wayne Mery (:wsmwk) from comment #7)
> > Is this a regression of jsmime checkin?

Yes. At least, the new mail notification garbling is.
Blocks: 858337
Flags: needinfo?(Pidgeot18)

Updated

2 years ago
Keywords: regressionwindow-wanted

Comment 19

2 years ago
It is a regression, so probably should be uplifted to tb36
tracking-thunderbird36: --- → ?
(Reporter)

Comment 20

2 years ago
Didn't make it into 36, so should go into 38 (or is this automatic since it's been checked in a while ago?)
tracking-thunderbird38: --- → ?
(Assignee)

Comment 21

2 years ago
(In reply to Jorg K from comment #20)
> Didn't make it into 36, so should go into 38 (or is this automatic since
> it's been checked in a while ago?)

If it landed on trunk in 37, and it's not backed out, it'll be in 38.
tracking-thunderbird37: ? → ---
tracking-thunderbird38: ? → ---
You need to log in before you can comment on or make changes to this bug.