[Usage] Mobile App Usage section is blank if no mobile data has been used

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ckreinbring, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8505118 [details]
Screenshot of usage chart with blank MAU section

Description:
When launching the Usage app without using any mobile data (usually immediately after the FTU or from using WiFi instead), there will be a blank area under the Mobile App Usage title bar instead of text.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141014040203
2) Launch the Usage app and navigate through the first time setup.
3) Observe the area below the Mobile App Usage section
  
Actual:
The area is completely blank.
  
Expected: 
The user will see a message that reads, "You have not used any mobile data yet.  Usage for each application will show up here when you do."
  
Environmental Variables:
Device: Flame 2.2
BuildID: 20141014040203
Gaia: 4f86c631e0465c0e56ccebeb1324fd28be9ea32f
Gecko: 54217864bae9
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 36.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
  
Repro frequency: 100%
See attached screenshot

Note: On the screenshot, 2.2 is on the left and 2.1 is on the right.
(Reporter)

Comment 1

4 years ago
But does not repro on Flame 2.1 nightly using full flash.
Actual result: The user will see a message that reads, "You have not used any mobile data yet.  Usage for each application will show up here when you do."

BuildID: 20141014001201
Gaia: 7e2e65a9668123b54c8cce5dacfdba6f4bd4672b
Gecko: 2325da834971
Gonk: 52c909e821d107d414f851e267dedcd7aae2cebf
Platform Version: 34.0
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
I cannot reproduce it on Flame 2.2:

BuildID: 20141022065708
Gaia: 3c90141
Gecko: 0dbdde5
Platform Version: 36.0a1

Chris, Would you mind rechecking this with a newer build?
Flags: needinfo?(ckreinbring)
(Reporter)

Comment 3

4 years ago
Unable to repro on today's 2.2 nightly with full flash.
Actual result: The user sees a message that reads, "You have not used any mobile data yet.  Usage for each application will show up here when you do."

BuildID: 20141022040201
Gaia: 4d7f051cede6544f4c83580253c743c22b0cb279
Gecko: ae4d9b4ff2ee
Gonk: 05aa7b98d3f891b334031dc710d48d0d6b82ec1d
Platform Version: 36.0a1
Firmware Version: V180
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(ckreinbring)
Per comment 2 and comment 3, closing this out as WFM. Please re open this bug if the issue occurs again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.