Closed Bug 1082974 Opened 5 years ago Closed 5 years ago

Video stops updating while during fullscreen transition in the youtube HTML5 video player.

Categories

(Core :: Audio/Video, defect, P5)

x86
macOS
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox33 --- wontfix
firefox35 --- wontfix
firefox36 --- affected
firefox37 - affected
firefox38 - affected

People

(Reporter: ehsan, Unassigned)

References

(Blocks 2 open bugs)

Details

This is really annoying as audio playback also stops.  Chrome doesn't seem to be affected by this issue.
Blocks: MSE
Priority: -- → P2
FWIW I can't reproduce the audio part on my mac with yesterday's nightly 37.0a1 (2015-01-06). Youtube with mse transitions to and from fullscreen without stopping audio playback. It doesn't update the video image continuously during the transition.

Reducing priority based on the reduced impact of this being video-only. Please reset to P2 if if you can still reproduce the audio dropout.
Priority: P2 → P5
[Tracking Requested - why for this release]:
bsmedberg says that Chad would like this fix for Beta 36 because we're trying to fix YouTube UX issues.
Flags: needinfo?(cweiner)
I'll track this for 37+ at this point but we need to reconcile Ralph marking this as a P5 with Chad wanting this fixed to set the appropriate priority and expectations.
The P5 was just for tracking purposes under the MSE tracking bug. It wasn't meant to reflect the value of the bug for Firefox overall. So I'd be happy to see a fix for this bug go in, but our team don't plan to invest in it in the near term.
Flags: needinfo?(giles)
What I meant by reconciling is that I would expect the fix for this bug to come from the media playback team. Chad has requested a fix. Can your team re-evaluate the priority of this bug? If not, let's set the appropriate expectation for the desktop team.

Sheila - Where does full screen support fit within the MSE plans?
Flags: needinfo?(smooney)
Flags: needinfo?(giles)
Flags: needinfo?(ajones)
To be clear, the problem as reported is resolved; we no longer reload the video. During the fullscreen transition I have continuous audio playback, but the video stops updating with new frames. Normal updates resume once the page re-layout triggers at the end of the transition.

It would be better if we kept updating, but I don't consider it critical. The media team has been concentrating on fixing crashes, stalls, and correct implementation of MSE and EME apis. P5 is an expression of my understanding of where it falls among those immediate priorities.
Flags: needinfo?(giles)
Summary: When going fullscreen in the youtube HTML5 video player, we start loading the video again → Video stops updating while during fullscreen transition in the youtube HTML5 video player.
Ralph - can you file a separate bug for that issue? I don't think it should block 36.
Flags: needinfo?(ajones) → needinfo?(giles)
(In reply to Ralph Giles (:rillian) from comment #6)
> To be clear, the problem as reported is resolved; we no longer reload the
> video. During the fullscreen transition I have continuous audio playback,
> but the video stops updating with new frames. Normal updates resume once the
> page re-layout triggers at the end of the transition.

Thank you for this clarification. I had misunderstood the bug and thought that the video did not resume playing even after the transition had completed.

> It would be better if we kept updating, but I don't consider it critical.
> The media team has been concentrating on fixing crashes, stalls, and correct
> implementation of MSE and EME apis. P5 is an expression of my understanding
> of where it falls among those immediate priorities.

I agree with the prioritization.

Chad - Do you still want to push on this in 36?
Flags: needinfo?(smooney)
No, the thing that was a blocker was the video restarting from the beginning. A pause in updates is a bad experience and we should fix it, but it's not a release blocker.
Flags: needinfo?(cweiner)
Dropping tracking based on comment 9. If this is to be fixed in 37, the earlier the better.
Ehsan - WFM on Windows, are you still experiencing this problem?
Flags: needinfo?(ehsan)
I can still reproduce the video not updating.  The audio playback seems to continue now.
Flags: needinfo?(ehsan)
I've filed bug 1152056 for eventual followup of the video issue. Closing this as the more serious audio issue is resolved.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(giles)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.