Error message is displayed when translating a review in editor tools

REOPENED
Unassigned

Status

P4
normal
REOPENED
4 years ago
3 years ago

People

(Reporter: madalin.cotetiu, Unassigned)

Tracking

unspecified
2014-10
x86_64
Windows 7

Details

(URL)

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Open AMO editor tools https://addons.allizom.org/en-US/editors/
2. Go to Queues-Moderated Reviews https://addons.allizom.org/en-US/editors/queue/reviews
3. Click on translate link for any review.

Expected results:
The review is translated.

Actual results:
The review is not translated, "Error loading translation" message is displayed.

Notes/Issues:
Verified in FF33 (Win7) issue can be reproduced in -dev and stage.
Screencast for this issue: http://screencast.com/t/wmrjDXCwnK
Assignee: nobody → vincent.agnano
Assignee: vincent.agnano → nobody
After investigation, it's because the GOOGLE_API_CREDENTIALS settings aren't set on stage. So the google translation api returns a "400 BAD REQUEST": "reason: KeyInvalid".

I'm assigning this to Jason, to see if he can set the same settings as for the production server.

I'm also need-info'ing Jorge, to confirm that this is indeed working on production.
Assignee: nobody → jthomas
Flags: needinfo?(jorge)
Priority: -- → P4
I can confirm it's working in prod.
Flags: needinfo?(jorge)
Excellent, thanks Jorge.

Jason, do you think we could have that working also on stage, by setting the proper credentials?
GOOGLE_API_CREDENTIALS is set on stage but it may not be correct. Please provide the correct credentials and I will modify stage settings.
I guess it must be the same as the one on production? It's set in the "private" module I believe.
Should we be using the same one as prod here? Should we generate a new one for stage?
I have no idea, Wil?
Flags: needinfo?(wclouser)
using the same as prod is fine.
Flags: needinfo?(wclouser)
Updated GOOGLE_API_CREDENTIALS on stage.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

4 years ago
I still can reproduce this issue for the majority of reviews.
Please view this screencast: http://screencast.com/t/KGMLCBrJihye
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

4 years ago
Assignee: jthomas → nobody
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.