Closed Bug 1083213 Opened 5 years ago Closed 5 years ago

"unexpected parser state" in netError.xhtml

Categories

(Firefox for Android :: General, defect)

35 Branch
All
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 569229

People

(Reporter: Margaret, Assigned: Margaret)

Details

I got this XML error when trying to open new tabs from about:home while I was on a plane with no wifi:

W/GeckoConsole( 7698): [JavaScript Error: "unexpected parser state" {file: "jar:jar:file:///data/app/org.mozilla.fennec_leibovic-1.apk!/assets/omni.ja!/chrome/chrome/content/netError.xhtml" line: 317 column: 59 source: "        <div id="ed_netInterrupt">&netInterrupt.longDesc2;</div>"}]

I'm having trouble trying to reproduce right now, but it was pretty bad to get a yellow XML parsing error page.

wesj, any idea what might be going wrong here? I was testing with a local build of fx-team from Monday.
Flags: needinfo?(wjohnston)
Nope. Haven't seen it...
Flags: needinfo?(wjohnston)
I saw this again when traveling. I think this happens if your network gets reset while connecting to a page.

We should look into the code to see what could cause this error.
tracking-fennec: --- → ?
Assignee: nobody → margaret.leibovic
Status: NEW → ASSIGNED
tracking-fennec: ? → 36+
This looks like a regression from bug 1042196. We should track for 34.
Blocks: 1042196
tracking-fennec: 36+ → 34+
Actually, this looks like a dupe of bug 569229, which is a core problem, so I don't think we should track this for Fennec.
No longer blocks: 1042196
Status: ASSIGNED → RESOLVED
tracking-fennec: 34+ → ---
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569229
Also, to note, I couldn't reproduce this bug if I loaded about:neterror manually with a netInterrupt error code.
You need to log in before you can comment on or make changes to this bug.