Closed Bug 1083244 Opened 6 years ago Closed 6 years ago

Document HTMLElement.findElements() on readthedocs

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla36

People

(Reporter: ahal, Assigned: ahal)

Details

Attachments

(1 file)

Currently marionette.findElement and marionette.findElements are documented on readthedocs, but there is no indication that it's also possible to call elem.findElements() to look for child nodes of that element.
I think the problem is that members are explicitly listed in the docs, rather than using the :members: directive. This means that anytime a method gets added, the documentation needs to be updated which is prone to human error.

This patch uses :members: where possible so new attributes and methods are automatically picked up. Note that the docs for the marionette object are split under different sub-headers.. so it isn't possible to use :members: without getting rid of the sub-headers.
Assignee: nobody → ahalberstadt
Status: NEW → ASSIGNED
Attachment #8505556 - Flags: review?(dburns)
Attachment #8505556 - Flags: review?(dburns) → review+
https://hg.mozilla.org/mozilla-central/rev/59263ec8ca1c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.