Closed Bug 1083285 Opened 5 years ago Closed 5 years ago

Noisy IndexedDB UnknownErr (IDBDatabase.cpp:776)

Categories

(Core :: DOM: IndexedDB, defect)

35 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox33 --- unaffected
firefox34 --- unaffected
firefox35 - affected
firefox36 - affected

People

(Reporter: alice0775, Assigned: bent.mozilla)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

[Tracking Requested - why for this release]:

STR
1. Start with newly created profile
2. Open about:home
3. Reload (F5)
[Tracking Requested - why for this release]:
What is the problem being reported here? Just that the warning shows up in the error console? Or is something breaking?
Flags: needinfo?(alice0775)
(In reply to ben turner [:bent] (use the needinfo? flag!) from comment #2)
> What is the problem being reported here? Just that the warning shows up in
> the error console? 

It is noisy when developing add-on.

>Or is something breaking?

May be not . (I am not sure)
Flags: needinfo?(alice0775)
Not tracking based only on noise in dev console, also do we know if this reproduces on Release channel builds?
Flags: needinfo?(alice0775)
Summary: IndexedDB UnknownErr: c:\builds\moz2_slave\m-cen-w32-ntly-000000000000000\build\dom\indexedDB\IDBDatabase.cpp:776 → Noisy IndexedDB UnknownErr (IDBDatabase.cpp:776)
(In reply to Lukas Blakk [:lsblakk] use ?needinfo from comment #4)
> Not tracking based only on noise in dev console, also do we know if this
> reproduces on Release channel builds?

Aurora35.0a2 and Nightly36.01 are affected. But not beta34.0 .
Flags: needinfo?(alice0775)
Attached file backtrace (obsolete) —
Here's a backtrace of where we hit this line, using my STR from bug 1093254 (a dupe of this bug that I just filed).

Looks like this happens when IndexedDB handles a "inner-window-destroyed" event.

bent, is there a reason we're spamming the browser console here? (This error-message is particularly cryptic; if it's not benefiting anyone, maybe we should remove it?)
Flags: needinfo?(bent.mozilla)
This logs a warning for each aborted readwrite/versionchange transaction and shows the file/line information for where it was created.
Assignee: nobody → bent.mozilla
Attachment #8516174 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Flags: needinfo?(bent.mozilla)
Attachment #8521697 - Flags: review?(khuey)
(In reply to Daniel Holbert [:dholbert] from comment #7)
> bent, is there a reason we're spamming the browser console here?

It needs a better message, and it's a warning, not an error. But yeah, this is an important one.
Comment on attachment 8521697 [details] [diff] [review]
Better warning, v1

Review of attachment 8521697 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/locales/en-US/chrome/dom/dom.properties
@@ +208,5 @@
>  # LOCALIZATION NOTE: Do not translate "KeyboardEvent.key" and "Dead".
>  KeyNameDeadKeysWarning=KeyboardEvent.key values starting with "Dead" are obsolete and will be merged into just "Dead". For more help https://developer.mozilla.org/en-US/docs/Web/API/KeyboardEvent.key
>  ImportXULIntoContentWarning=Importing XUL nodes into a content document is deprecated. This functionality may be removed soon.
>  XMLDocumentLoadPrincipalMismatch=Use of document.load forbidden on Documents that come from other Windows. Only the Window in which a Document was created is allowed to call .load on that Document. Preferably, use XMLHttpRequest instead.
> +IndexedDBTransactionAbortNavigation=An IndexedDB transaction that was not yet complete has been aborted due to page navigation.
\ No newline at end of file

This needs a note saying not to translate IndexedDB.
Attachment #8521697 - Flags: review?(khuey) → review+
https://hg.mozilla.org/mozilla-central/rev/dd689d9e6620
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
See Also: → 1118055
You need to log in before you can comment on or make changes to this bug.