Closed Bug 1083287 Opened 5 years ago Closed 5 years ago

[Contacts] The top left cross is not visible when starting a "pick" activity

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1085251
blocking-b2g 2.2+
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- affected

People

(Reporter: julienw, Unassigned)

References

Details

(Keywords: regression)

STR:
1. launch Messages
2. press the "new message" button
3. press the "+" button
4. wait that the contacts app is displayed
=> no cross at the top left to exit the activity, and we have the 2 icons on the right.
5. press home
6. press Messages (should display the activity again)
=> the cross appears, and we don't have the 2 icons anymore

Flame v184, 2.2 Gecko/Gaia from yesterday.
Keywords: regression
Asking for QAWANTED to check if it's happening in 2.1 as well.
Keywords: qawanted
Tested with Shallow Flash on 319mb using Engineering builds

This bug repro's on Flame KK builds: Flame 2.2 KK

Actual Results: The close button (X) is missing from the contacts list window when trying to add a contact to the messages app. The button reappears when leaving the app then returning to the app.

Repro Rate: 2/2

Environmental Variables:
Device: Flame Master KK
BuildID: 20141014064254
Gaia: de254419f3553f48187d003ee8e38034b429f069
Gecko: eb1b8ecbefde
Version: 36.0a1 (Master) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-----------------------------------------------------------------
-----------------------------------------------------------------

This bug does NOT repro on Flame kk build: Flame 2.1 KK, flame 2.0 KK

Actual Result: The close button (X) is present in the contacts list when you arrive from messages app.

Repro Rate: 0/6

Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141015040132
Gaia: 82565292c0fa86e3ddcda290cae7f5cb702f654c
Gecko: d8d578cb569c
Version: 34.0 (2.1) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141014194629
Gaia: c6c6116ca225c2c934220ae6867e5a3256d65e00
Gecko: 24a2aa6bf1c4
Version: 32.0 (2.0) 
Firmware Version: L1TC10011800
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: croesch
QA Contact: jmitchell
B2G-Inbound Regression Window:

Last Working:
Device: Flame 2.2
Build ID: 20140924070754
Gaia: e68f68150b89887db48acd59b8a66c3cb7f9a5bc
Gecko: fd8fbe038ccc
Version: 35.0a1 (2.2)
Firmware Version: v184
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0

First Broken:
Device: Flame 2.2
Build ID: 20140924084356
Gaia: eb0fb5e0c6788da74a0936916c3abd1cae750070
Gecko: 227edbd2530c
Version: 35.0a1 (2.2)
Firmware Version: v184
User Agent: Mozilla/5.0 (Mobile; rv:35.0) Gecko/35.0 Firefox/35.0


Gaia/Gecko Swap
Last Working Gaia First Broken Gecko: Issue does NOT reproduce
Gaia: e68f68150b89887db48acd59b8a66c3cb7f9a5bc
Gecko: 227edbd2530c
First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: eb0fb5e0c6788da74a0936916c3abd1cae750070
Gecko: fd8fbe038ccc

Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/e68f68150b89887db48acd59b8a66c3cb7f9a5bc...eb0fb5e0c6788da74a0936916c3abd1cae750070


Broken by Bug 1071722 - Can you take a look Francisco?
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Flags: needinfo?(francisco)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
triage: identifiable regression which breaks function
blocking-b2g: 2.2? → 2.2+
Thanks will take a look
Flags: needinfo?(francisco)
(please add regressing bugs in the Blocks line, it helps when later on we (for example) need to uplift bugs..)
Blocks: 1071722
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1085251
You need to log in before you can comment on or make changes to this bug.