If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Lag when typing on keyboard after press Next button during configuration of Email App

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mac, Assigned: jrburke)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140923175406

Steps to reproduce:

1. Open Email App
2. On the 'New Account' screen provide valid name and email address.
3. Tap on 'Next' button.
4. After a while 'Manual setup appears.


Actual results:

When typing on any field (i.e. Hostname) noticable lag occurs, if user is typing continuously then typed word appears even 1-2 seconds later.


Expected results:

It should work fluently. If user taps on 'Manual Setup' instead of 'Next' (point 3.) then same scenario works properly - no lags.


Found on:

Alcatel One Touch Fire production (got from T-mobile Poland)
B2G version: 2.2.0.0-prerelease master
Platform version: 36.0a1
Build Identifier: 20141015040201 
Git commit info: 2014-10-14 16:11:51 5f1f0960
(Reporter)

Updated

3 years ago
Component: General → Gaia::E-Mail
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Assignee)

Comment 1

3 years ago
Initial tests on hamachi flashed with master:

1) Tapping Next from setup_account_info, has the slower typing
2) Tapping Manual Config from setup_account_info, faster typing.

Perhaps there is some autoconfig stuff in play (extra network connections still going?), or something more expensive setup_progress is doing (animated progress icon?), to contribute to the slowdown. More investigation to follow.
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

3 years ago
Created attachment 8505796 [details] [review]
GitHub pull request

It was the spinner in the setup_progress card. By using display: none when not in view, it restored typing speed.

Asking :mcav for review, should be an easy one, just a CSS change, with notes in the pull request.

This issue would also show up in 2.1 as well as master, since the change to use a setup_progress card at this point in the flow is from the xoauth changes done for bug 1059100.

When I tried on the flame device, this issue is not detectable, so really an issue with the less powerful devices, like the hamachi.
Assignee: nobody → jrburke
Status: NEW → ASSIGNED
Attachment #8505796 - Flags: review?(m)
(Assignee)

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Comment on attachment 8505796 [details] [review]
GitHub pull request

Since I don't have a lower-end device in a state suitable for testing, I'll take your word for it that it helps. Seems sane to me.
Attachment #8505796 - Flags: review?(m) → review+
(Assignee)

Comment 4

3 years ago
Gaia was closed when I was going to merge for the first time, then forgot this was not merged. Rebased to master, and the try thing does not complete, but it is completely unrelated to this very targeted email-only CSS change. So merged.

Merged in master:
https://github.com/mozilla-b2g/gaia/commit/7fe52b81bdffdb5f1371aeb1a93934b9c1063379

from pull request:
https://github.com/mozilla-b2g/gaia/pull/25197
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.