DUT volume is not changing while changing the BT volume on BT headset device

RESOLVED WORKSFORME

Status

Firefox OS
Bluetooth
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: bhargavg1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caf priority: p2][CR 739425])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
teps to Reproduce:
-------------------
1. Copy clips to sdcard
2. Start playback by launching the music app
3. Pair and connect BT headset, playback routing to BT headset when BT connected
4. Verify DUT volume While playback is on BT
5. Now change the BT headset volume and verify the DUT volume
5. DUT volume doesn't change accordingly

Expected result: DUT volume should change according to BT headset volume 

Actual Result: DUT volume is not changing while changing the BT volume on BT headset device

Note: The same issue verified and reproduced with Plantronics and SONY MW600 BT headsets as well

BT Headset Used: Sony DR-BTN200
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?
Please provide snoop log. Thanks.
Flags: needinfo?(bhargavg1)
(Reporter)

Updated

4 years ago
Flags: needinfo?(bhargavg1)
(Reporter)

Updated

4 years ago
Flags: needinfo?(vasanth)
(In reply to bhargavg1 from comment #0)
> teps to Reproduce:
> -------------------
> 1. Copy clips to sdcard
> 2. Start playback by launching the music app
> 3. Pair and connect BT headset, playback routing to BT headset when BT
> connected
> 4. Verify DUT volume While playback is on BT
> 5. Now change the BT headset volume and verify the DUT volume
> 5. DUT volume doesn't change accordingly
> 
> Expected result: DUT volume should change according to BT headset volume 
> 
> Actual Result: DUT volume is not changing while changing the BT volume on BT
> headset device
> 
> Note: The same issue verified and reproduced with Plantronics and SONY MW600
> BT headsets as well
> 
> BT Headset Used: Sony DR-BTN200

Hi,
What's the expected behavior here?
I assume you expected the volume of music (normal mode, PCM volume) get changed, or in-call (BT SCO) volume?
Flags: needinfo?(bhargavg1)

Updated

4 years ago
Whiteboard: [CR 739425] → [caf priority: p2][CR 739425]

Comment 4

4 years ago
Hi bhargav, can you provide the reason why you nominate this as a blocker? thanks
Flags: needinfo?(bhargavg1)

Comment 5

4 years ago
Created attachment 8505996 [details]
btsnoop_hci_enabled.log

While collecting snoop logs,
1. BT headset is paired with DUT.
2. Did some play, pause operations in Music app
3. Then changed volume by pressing BT headset vol up/down buttons
4. We can notice that volume is changed in BT headset but it is not updating device's volume level.
Flags: needinfo?(vasanth)

Updated

4 years ago
Blocks: 1025317
Blocking 2.1 FC and CC = 2.1+.
blocking-b2g: 2.1? → 2.1+

Updated

4 years ago
No longer blocks: 1025317
shawn, does comment #5 help or you need more info here?
Flags: needinfo?(shawnjohnjr)
Flags: needinfo?(shawnjohnjr)
Flags: needinfo?(bhargavg1)
(In reply to vasanth from comment #5)
> Created attachment 8505996 [details]
> btsnoop_hci_enabled.log
> 
> While collecting snoop logs,
> 1. BT headset is paired with DUT.
> 2. Did some play, pause operations in Music app
> 3. Then changed volume by pressing BT headset vol up/down buttons
> 4. We can notice that volume is changed in BT headset but it is not updating
> device's volume level.
Although this bug marked as 2.1+, I still want to clarify a few things here.
There two ways to sync volume:
1. HFP profile AT command "+VGS", this changes "BT SCO volume, which is in-call bluetooth volume"
2. AVRCP 1.4 Volume sync (absolute volume feature), this does not support on v2.1.

From the log, I did not see any "+VGS command" or AVRCP 1.4 absolute volume sync.
The log shows the accessory supports AVRCP 1.3 only.

There are many headsets only support their local volume change but not AVRCP absolute volume.
Can you help to cross reference using other Android phones with the same Bluetooth headset?
Flags: needinfo?(vasanth)
Note: We're still clarifying this bug is related to headset design or function failure. We need more input for various headsets design.
(In reply to Shawn Huang [:shawnjohnjr] from comment #8)
> (In reply to vasanth from comment #5)
> Although this bug marked as 2.1+, I still want to clarify a few things here.
> There two ways to sync volume:
> 1. HFP profile AT command "+VGS", this changes "BT SCO volume, which is
> in-call bluetooth volume"
I can confirm '+VGS (Gain of Speaker)' works, BT SCO volume will be changed.
> 2. AVRCP 1.4 Volume sync (absolute volume feature), this does not support on
> v2.1.
I doubt many Bluetooth headsets actually support this, and I don't intend to add this feature for v2.1.
Given this fact, I really don't think this is a blocker. Let's wait for feedback Comment 8.

Comment 11

4 years ago
(In reply to Shawn Huang [:shawnjohnjr] from comment #8)
> Can you help to cross reference using other Android phones with the same
> Bluetooth headset?

Hi Shawn,
That specific headset doesn't update volume in Android as well whereas some other headsets do.
We tried volume change only during audio playback so its *not* related to BT SCO volume.

As you mentioned, AVRCP 1.4 Volume sync is not supported yet in v2.1,
not sure we should continue to look into this?
Flags: needinfo?(vasanth)
(In reply to vasanth from comment #11)
> (In reply to Shawn Huang [:shawnjohnjr] from comment #8)
> > Can you help to cross reference using other Android phones with the same
> > Bluetooth headset?
> 
> Hi Shawn,
> That specific headset doesn't update volume in Android as well whereas some
> other headsets do.
> We tried volume change only during audio playback so its *not* related to BT
> SCO volume.
It depends on how bluetooth headsets design, some headsets send +VGS even during audio playback.
> As you mentioned, AVRCP 1.4 Volume sync is not supported yet in v2.1,
> not sure we should continue to look into this?
I don't think we need to continue to look into this. And the headsets you tested may not support AVRCP 1.4 absolute volume feature. Can we close it?

Comment 13

4 years ago
(In reply to Shawn Huang [:shawnjohnjr] from comment #12)
> It depends on how bluetooth headsets design, some headsets send +VGS even
> during audio playback.
Got it. Thanks!

> I don't think we need to continue to look into this. And the headsets you
> tested may not support AVRCP 1.4 absolute volume feature. Can we close it?
Sure.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 2.1+ → ---
You need to log in before you can comment on or make changes to this bug.